Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1887877 - supercollider segmentation fault in qt doActivate when starting
Summary: supercollider segmentation fault in qt doActivate when starting
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: supercollider
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tristan Cacqueray
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-13 14:02 UTC by Tristan Cacqueray
Modified: 2020-10-23 22:13 UTC (History)
2 users (show)

Fixed In Version: supercollider-3.11.1-1.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-23 22:13:33 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1881915 0 unspecified CLOSED kstars segmentation fault in doActivate when starting 2021-02-22 00:41:40 UTC

Description Tristan Cacqueray 2020-10-13 14:02:13 UTC
Description of problem:

scide segfault on start

Version-Release number of selected component (if applicable): supercollider-3.10.4-6.fc33.x86_64


How reproducible:

always


Additional info:

```
Thread 1 "scide" received signal SIGSEGV, Segmentation fault.
0x00007ffff6e22d6b in void doActivate<false>(QObject*, int, void**) () from /lib64/libQt5Core.so.5
(gdb) bt
#0  0x00007ffff6e22d6b in void doActivate<false>(QObject*, int, void**) () from /lib64/libQt5Core.so.5
#1  0x00007ffff735f3c2 in QGuiApplication::screenAdded(QScreen*) () from /lib64/libQt5Gui.so.5
#2  0x00007ffff734f71c in QWindowSystemInterface::handleScreenAdded(QPlatformScreen*, bool) () from /lib64/libQt5Gui.so.5
#3  0x00007fffea1cf8e0 in QXcbConnection::initializeScreens() () from /lib64/libQt5XcbQpa.so.5
#4  0x00007fffea1ab140 in QXcbConnection::QXcbConnection(QXcbNativeInterface*, bool, unsigned int, char const*) () from /lib64/libQt5XcbQpa.so.5
#5  0x00007fffea1addf3 in QXcbIntegration::QXcbIntegration(QStringList const&, int&, char**) () from /lib64/libQt5XcbQpa.so.5
#6  0x00007fffea2a946f in QXcbIntegrationPlugin::create(QString const&, QStringList const&, int&, char**) () from /usr/lib64/qt5/plugins/platforms/libqxcb.so
#7  0x00007ffff735842b in QPlatformIntegrationFactory::create(QString const&, QStringList const&, int&, char**, QString const&) () from /lib64/libQt5Gui.so.5
#8  0x00007ffff7362b70 in QGuiApplicationPrivate::createPlatformIntegration() () from /lib64/libQt5Gui.so.5
#9  0x00007ffff7364180 in QGuiApplicationPrivate::createEventDispatcher() () from /lib64/libQt5Gui.so.5
#10 0x00007ffff6dfae96 in QCoreApplicationPrivate::init() () from /lib64/libQt5Core.so.5
#11 0x00007ffff7366ad4 in QGuiApplicationPrivate::init() () from /lib64/libQt5Gui.so.5
#12 0x00007ffff7999ef9 in QApplicationPrivate::init() () from /lib64/libQt5Widgets.so.5
#13 0x00005555555b5479 in main ()
```

Comment 1 Tristan Cacqueray 2020-10-13 14:32:35 UTC
That seems related to lto and missing PIC flag. Rebuilding did not work though because of:

```
/builddir/build/BUILD/SuperCollider-Source/QtCollider/primitives/prim_QPen.cpp:37:21: error: aggregate 'QPainterPath path' has incomplete type and cannot be defined
   37 | static QPainterPath path;
      |                     ^~~~
/builddir/build/BUILD/SuperCollider-Source/QtCollider/primitives/prim_QPen.cpp: In function 'bool QtCollider::beginPainting(QPainter*, QObject*)':
/builddir/build/BUILD/SuperCollider-Source/QtCollider/primitives/prim_QPen.cpp:61:25: error: invalid use of incomplete type 'class QPainterPath'
```

I started another scratch build using the latest supercollider version here: https://koji.fedoraproject.org/koji/taskinfo?taskID=53380131

Comment 2 seb 2020-10-13 15:27:11 UTC
Additional info: https://bugzilla.redhat.com/show_bug.cgi?id=1887190

Comment 3 Tristan Cacqueray 2020-10-13 16:43:11 UTC
Alright, latest version and -fPIC fixed the issue. Here is the correct scratch build: https://koji.fedoraproject.org/koji/taskinfo?taskID=53381214 and the f33 build is happening here: https://koji.fedoraproject.org/koji/taskinfo?taskID=53386652

Comment 4 Fedora Update System 2020-10-13 20:49:06 UTC
FEDORA-2020-e6d5c17f55 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-e6d5c17f55

Comment 5 Fedora Update System 2020-10-13 22:39:52 UTC
FEDORA-2020-e6d5c17f55 has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-e6d5c17f55`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-e6d5c17f55

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2020-10-23 22:13:33 UTC
FEDORA-2020-e6d5c17f55 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.