Bug 1887891 - add Recommends: nm-connection-editor
Summary: add Recommends: nm-connection-editor
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-control-center
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kalev Lember
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F33FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2020-10-13 14:29 UTC by Chris Murphy
Modified: 2021-01-22 15:17 UTC (History)
11 users (show)

Fixed In Version: gnome-control-center-3.38.1-2.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-22 15:06:26 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github fedora-silverblue issue-tracker issues 88 0 None closed Package nm-connection-editor as a flatpak on fedora registry 2021-02-02 17:32:29 UTC

Description Chris Murphy 2020-10-13 14:29:44 UTC
Discussed this issue during Workstation WG open floor today:
https://github.com/fedora-silverblue/issue-tracker/issues/88

nm-connection-editor is in Fedora Workstation because it's brought in by Anaconda, but isn't on Silverblue. Solve this by adding a Recommends: nm-connection-editor to gnome-control-center.

It's already explicitly in xfce-desktop, mate-desktop, cinnamon-desktop, lxde-desktop, lxqt-desktop groups.

Comment 1 Fedora Blocker Bugs Application 2020-10-13 14:33:18 UTC
Proposed as a Freeze Exception for 33-final by Fedora user chrismurphy using the blocker tracking app because:

 Has no impact on any release blocking image. But is preferred to get it into Fedora 33 Silverblue sooner than later.

Comment 2 Adam Williamson 2020-10-13 17:01:11 UTC
+3 votes in https://pagure.io/fedora-qa/blocker-review/issue/164 , accepting.

Comment 3 Kalev Lember 2020-10-13 17:10:05 UTC
gnome-control-center-3.38.1-2.fc33 build under way that adds the recommends.

Comment 4 Fedora Update System 2020-10-13 17:24:27 UTC
FEDORA-2020-fbbbba1b6a has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-fbbbba1b6a

Comment 5 Fedora Update System 2020-10-14 00:42:26 UTC
FEDORA-2020-fbbbba1b6a has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 6 Thomas Haller 2020-11-18 16:36:18 UTC
Doesn't this counteract other plans?


nm-connection-editor has

  NotShowIn=GNOME;

and it does so, because it is deemed to be confusing to the user to find two applications for configuring the network.
On the other hand, having no GUI path to start nm-connection-editor is also a problem.


This was worse, because gnome-control-center for a long time had a dependency on nm-connection-editor. So, in practice you always had nm-connection-editor in GNOME installed, hence the need to hide it.

The long discussed solution was to

  - remove that dependency of gnome-control-center for nm-c-e, so that a default installation would not have nm-c-e installed.

  - remove the NotShowIn=GNOME, so when a user still installed it (intentionally), then nm-c-e would be shown in the GNOME bar.

It took a long time to get there, but we are now ready to remove "NotShowIn=GNOME".


See for example
https://gitlab.gnome.org/GNOME/network-manager-applet/-/issues/55
https://bugzilla.redhat.com/show_bug.cgi?id=1493508#c10
https://bugzilla.redhat.com/show_bug.cgi?id=1715143 


Anyway, so we did all the splitting of nm-c-e and g-c-c, and you can now install them independently.
g-c-c now "Recommends:nm-c-e" and Fedora installs nm-c-e by default. Doesn't that counteract that effort?

At this point, we would remove the NotShowIn=GNOME. Are we now ready for this?

@CC Allan.

Comment 7 Michael Catanzaro 2020-11-18 16:52:19 UTC
The NetworkManager developers have waited long enough to remove the NotShowIn=GNOME. So I think it's OK to do that for F34, and up to us to the WG to decide how to handle that. I know Matthias is also not fond of using NotShowIn= to hide applications.

I'd prefer to ensure nm-connection-editor is not installed by default. Any desired features that are missing from there should be added to gnome-control-center instead. However, I think the opinion of the rest of the working group was to add the Recommends. This means we would just have two separate network configuration tools.

Comment 8 Kalev Lember 2020-11-19 09:47:05 UTC
> I'd prefer to ensure nm-connection-editor is not installed by default. Any desired features that are missing from there should be added to gnome-control-center instead. However, I think the opinion of the rest of the working group was to add the Recommends. This means we would just have two separate network configuration tools.

I'd prefer to ensure nm-connection-editor is not installed by default as well. And I think the rest of the Workstation WG would like that too.

I think you misunderstood what we did here, Michael. The recommends were added to gnome-control-center just to bring Silverblue in line with Workstation where nm-connection-editor was already getting pre-installed due to anaconda pulling it in. As soon as we can get rid of the nm-connection-editor dep in anaconda I think we can drop the recommends from gnome-control-center as well.

Just to reiterate, the recommends were just a stop gap measure to bring Silverblue package set in line with Workstation. The intent was not at all to obstruct the plans of getting rid of it in the default install.

Comment 9 Kalev Lember 2020-11-19 09:50:37 UTC
> The long discussed solution was to
> 
>   - remove that dependency of gnome-control-center for nm-c-e, so that a default installation would not have nm-c-e installed.
> 
>   - remove the NotShowIn=GNOME, so when a user still installed it (intentionally), then nm-c-e would be shown in the GNOME bar.
> 
> It took a long time to get there, but we are now ready to remove "NotShowIn=GNOME".

That's awesome! Thanks for getting it to this point.

However, it's really 'anaconda-gui' that has a hard dep on nm-connection-editor that is pulling it onto Workstation install media. Please talk to anaconda people first to get this dropped.

Comment 10 Thomas Haller 2020-11-19 11:07:28 UTC
> I think you misunderstood what we did here, Michael. The recommends were added to gnome-control-center just to bring Silverblue in line with Workstation where nm-connection-editor was already getting pre-installed due to anaconda pulling it in. As soon as we can get rid of the nm-connection-editor dep in anaconda I think we can drop the recommends from gnome-control-center as well.

Anaconda needs nm-connection-editor during installation. I think that dependency will not be dropped. The issue is more that the package is afterwards still installed.

That seems more like an undesired bug, not something that Silverblue should to repeat.

Comment 11 Radek Vykydal 2020-11-19 11:48:07 UTC
(In reply to Thomas Haller from comment #10)
> > I think you misunderstood what we did here, Michael. The recommends were added to gnome-control-center just to bring Silverblue in line with Workstation where nm-connection-editor was already getting pre-installed due to anaconda pulling it in. As soon as we can get rid of the nm-connection-editor dep in anaconda I think we can drop the recommends from gnome-control-center as well.
> 
> Anaconda needs nm-connection-editor during installation. I think that
> dependency will not be dropped. The issue is more that the package is
> afterwards still installed.

Actually on Workstation/Live Anaconda does not offer network configuration and points to using live environment tools instead. So we could probably try to remove nm-c-e from Live Installer environment which would remove it from installed system as well, as we are installing by rsync in this (LiveOS) type of installation.

(But for other types of installation using installer iso/image, like Fedora Server, we are not going to drop nm-c-e for network configuration in the near future.)

> 
> That seems more like an undesired bug, not something that Silverblue should
> to repeat.

Maybe a BZ for Anaconda to remove nm-c-e from installed Workstation / Live environment should be filed. I am not sure how difficult it would be but we could assess it in the team having the BZ.

Comment 12 Michael Catanzaro 2020-11-19 15:35:22 UTC
I think the most plausible way to get the behavior we want is to remove the Requires: nm-connection-editor from anaconda, even though it really is required, and instead manually ensure that nm-connection-editor is always installed via comps or kickstart on any image where anaconda needs it. I know that's not a great solution, but this isn't an easy problem.

Alternatively, we'd need to finally implement some way to uninstall anaconda and nm-connection-editor postinstall (which we've considered doing via kickstart).

Comment 13 Michael Catanzaro 2021-01-22 14:58:45 UTC
(In reply to Michael Catanzaro from comment #12)
> I think the most plausible way to get the behavior we want is to remove the
> Requires: nm-connection-editor from anaconda, even though it really is
> required, and instead manually ensure that nm-connection-editor is always
> installed via comps or kickstart on any image where anaconda needs it. I
> know that's not a great solution, but this isn't an easy problem.

Yeah let's do this.

Kalev, can we revert the change to the gnome-control-center RPM? IMO there is no reason we should make Silverblue worse to match Workstation in the meantime.

Comment 14 Kalev Lember 2021-01-22 15:04:57 UTC
Please do so only after anaconda has removed the requires on nm-connection-editor RPM. Otherwise we are back in the situation where Silverblue and Workstation don't match up (which is what the Recommends in gnome-control-center addressed).

Can you do a PR for anaconda to drop the hard requires on nm-connection-editor?

Comment 15 Kalev Lember 2021-01-22 15:06:26 UTC
Let's close this again -- this was fixed a long time ago and there's no point in spamming all of the involved blocker bug people.

Comment 16 Michael Catanzaro 2021-01-22 15:09:33 UTC
Reported bug #1919312 to remove the anaconda dep.

Comment 17 Kalev Lember 2021-01-22 15:17:00 UTC
Nice, thanks!


Note You need to log in before you can comment on or make changes to this bug.