Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1887899 - Accessibility: Project selection drop down items are not highlighted on up/down arrow key press
Summary: Accessibility: Project selection drop down items are not highlighted on up/do...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.7
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.7.0
Assignee: Harish Govindarajulu
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-13 14:44 UTC by Harish Govindarajulu
Modified: 2020-12-03 18:13 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-12-03 18:13:26 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Harish Govindarajulu 2020-10-13 14:44:08 UTC
Description of problem:
When scrolling through the project selection dropdown using up/down arrow keys, the current item is not highlighted/ visible to user

Note: The selection from the list still works. To test, navigate through the list using up/down arrow keys and hit enter


Version-Release number of selected component (if applicable):
4.6

How reproducible:
Always

Steps to Reproduce:
1. From operators install page, click on the project selection dropdown
2. Using up/down arrow keys, scroll through the list
3. The current selected item is not highlighted

Expected results:
The current item should be highlighted for selection

Comment 1 Harish Govindarajulu 2020-10-23 19:38:32 UTC
This fix involves refactoring the dropdown component. I and @Jon looked into and decided that we would hold off on fixing this bug until the component is refactored.

Comment 2 Harish Govindarajulu 2020-12-03 18:13:26 UTC
Spoke to Sam. Since it's a low priority and doesn't break the accessibility, it was decided that this will not be fixed.


Note You need to log in before you can comment on or make changes to this bug.