Bug 1887905 - mock: unowned /usr/share/cheat directory
Summary: mock: unowned /usr/share/cheat directory
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mock
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Copr Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-13 14:56 UTC by Carl George 🤠
Modified: 2020-12-31 01:21 UTC (History)
7 users (show)

Fixed In Version: mock-2.7-1.fc33 mock-2.7-1.fc32 mock-2.8-1.el8 mock-2.8-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-12-10 01:13:41 UTC
Type: Bug


Attachments (Terms of Use)

Description Carl George 🤠 2020-10-13 14:56:40 UTC
Description of problem:
The mock package installs the file /usr/share/cheat/mock, but does not own the /usr/share/cheat directory, or require any package that owns it.  This is not allowed by the package guidelines.

Version-Release number of selected component (if applicable):
mock-2.6-1.fc31
mock-2.6-1.fc32
mock-2.6-1.fc33
mock-2.6-1.fc34

How reproducible:
always

Steps to Reproduce:
1. dnf install mock
2. rpm -qf /usr/share/cheat

Actual results:
file /usr/share/cheat is not owned by any package

Expected results:
The simplest solution would be for mock to own that directory.  Alternatively, the cheat file could be split into it's own optional subpackage that requires the cheat package.  Another possibility would be for that directory to be owned by the filesystem package, similar to /usr/share/man.

Additional info:
https://docs.fedoraproject.org/en-US/packaging-guidelines/#_file_and_directory_ownership
https://docs.fedoraproject.org/en-US/packaging-guidelines/UnownedDirectories/

Comment 1 Pavel Raiskup 2020-10-13 15:20:25 UTC
Thank you for the report, upstream PR:
https://github.com/rpm-software-management/mock/pull/643

Comment 2 Miroslav Suchý 2020-10-14 10:23:19 UTC
Note that owning the directory is complicated. Mock situation is described in :
  https://docs.fedoraproject.org/en-US/packaging-guidelines/#_the_directory_is_owned_by_a_package_which_is_not_required_for_your_package_to_function

Also note that not everyone follows it. See /etc/logrotate.d/ and /etc/bash_completion.d/

In *my* opinion it is better to not owning the directory, because if `cheat` decide to change attributes of this directory, then we all have to synchronize.

But yeah, guidelines say MUST. So we change it.

Comment 3 Fedora Update System 2020-12-01 09:42:38 UTC
FEDORA-2020-afe3cb8dbc has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-afe3cb8dbc

Comment 4 Fedora Update System 2020-12-01 09:43:26 UTC
FEDORA-2020-54d3e6d1c1 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-54d3e6d1c1

Comment 5 Fedora Update System 2020-12-01 09:43:47 UTC
FEDORA-EPEL-2020-646d5f7450 has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-646d5f7450

Comment 6 Fedora Update System 2020-12-01 09:44:01 UTC
FEDORA-EPEL-2020-77cf1cc1a9 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-77cf1cc1a9

Comment 7 Fedora Update System 2020-12-02 01:38:45 UTC
FEDORA-2020-afe3cb8dbc has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-afe3cb8dbc`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-afe3cb8dbc

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2020-12-02 02:09:30 UTC
FEDORA-EPEL-2020-646d5f7450 has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-646d5f7450

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Fedora Update System 2020-12-02 02:15:27 UTC
FEDORA-EPEL-2020-77cf1cc1a9 has been pushed to the Fedora EPEL 7 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-77cf1cc1a9

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2020-12-02 02:27:07 UTC
FEDORA-2020-54d3e6d1c1 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-54d3e6d1c1`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-54d3e6d1c1

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Fedora Update System 2020-12-10 01:13:41 UTC
FEDORA-2020-afe3cb8dbc has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 12 Fedora Update System 2020-12-10 01:26:44 UTC
FEDORA-2020-54d3e6d1c1 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 13 Fedora Update System 2020-12-16 00:25:01 UTC
FEDORA-EPEL-2020-e8977f0629 has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-e8977f0629

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 14 Fedora Update System 2020-12-16 01:57:59 UTC
FEDORA-EPEL-2020-3361ef3fc2 has been pushed to the Fedora EPEL 7 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-3361ef3fc2

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 15 Fedora Update System 2020-12-31 00:36:43 UTC
FEDORA-EPEL-2020-e8977f0629 has been pushed to the Fedora EPEL 8 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 16 Fedora Update System 2020-12-31 01:21:50 UTC
FEDORA-EPEL-2020-3361ef3fc2 has been pushed to the Fedora EPEL 7 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.