Bug 1887932 - Endpoint /katello/api/activation_keys/:activation_key_id/subscriptions missing in /api/v2
Summary: Endpoint /katello/api/activation_keys/:activation_key_id/subscriptions missin...
Keywords:
Status: NEW
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Activation Keys
Version: 6.8.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Cole Higgins
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-13 15:32 UTC by Lukáš Hellebrandt
Modified: 2020-10-15 14:15 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Target Upstream Version:


Attachments (Terms of Use)

Description Lukáš Hellebrandt 2020-10-13 15:32:12 UTC
Description of problem:
While there is endpoint "/katello/api/activation_keys/:activation_key_id/subscriptions" mentioned in Apidoc, it's not shown in https://$SATELLITE/api/v2 . These should match. This is a regression because it is shown in 6.7's /api/v2 but I think this should NOT be a blocker - I doubt anyone will notice.

Version-Release number of selected component (if applicable):
6.8, regression

How reproducible:
Deterministic

Steps to Reproduce:
1. Go to /apidoc
2. Go to /api/v2

Actual results:
"/katello/api/activation_keys/:activation_key_id/subscriptions" is missing in /api/v2

Expected results:
It should be present in both


Note You need to log in before you can comment on or make changes to this bug.