Bug 18882 - kernel server-tuning patch incompatible with Win4Lin
Summary: kernel server-tuning patch incompatible with Win4Lin
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.0
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-11 11:09 UTC by David F. Elliott
Modified: 2007-03-27 03:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-12 10:46:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David F. Elliott 2000-10-11 11:09:22 UTC
Building a kernel with the server-tuning patch and win4lin patch applied
generates a kernel which does not boot. The machine resets before the
kernel displays any messages.

This is not a bug report in the general sense of the word, but I figured
that people building kernels should be aware of the issue.  Hopefully
NeTraverse (nee TreLos) can determine which specific define was changed
that is causing the problem.

Comment 1 David F. Elliott 2000-10-12 10:46:03 UTC
According to Netraverse, it is most likely the NR_TASKS change since the max is
4092 for a normal kernel, apm takes away 2 leaving 4090, and win4lin takes away
256 leaving slightly more than 3800.

I have not yet tested this hypothesis, but it seems correct.

Comment 2 Alan Cox 2000-11-28 17:32:19 UTC
This would appear to be a problem for Trelos not Red Hat. It's stil good to have
the info so other
folks can find it in the database however.

Thanks



Note You need to log in before you can comment on or make changes to this bug.