Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1888202 - F33 RC1.1 Live images show a pre-release warning
Summary: F33 RC1.1 Live images show a pre-release warning
Keywords:
Status: CLOSED DUPLICATE of bug 1888197
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ben Cotton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F33FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2020-10-14 11:27 UTC by Kamil Páral
Modified: 2020-10-14 15:56 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-14 15:56:47 UTC
Type: Bug


Attachments (Terms of Use)

Description Kamil Páral 2020-10-14 11:27:46 UTC
According to our OpenQA tests, F33 RC1.1 Workstation and KDE Live images show a pre-release warning, while they shouldn't:

https://openqa.fedoraproject.org/tests/694690#step/_boot_to_anaconda/14
https://openqa.fedoraproject.org/tests/694707#step/_boot_to_anaconda/14

I'm still downloading those images to verify, but reporting ASAP.

Comment 1 Kamil Páral 2020-10-14 11:46:23 UTC
I can confirm that the pre-release warnings are really there on both Lives.

Comment 2 Kamil Páral 2020-10-14 11:49:17 UTC
I think this is actually caused by bug 1888197, because that's how the Live images determine the pre-release status... (?)

Comment 3 Adam Williamson 2020-10-14 15:56:47 UTC
Yeah, that's exactly right. On live images, the installer winds up falling back to a check of the release field for the package that provides system-release; if it's 1 or greater, anaconda runs in 'final' mode, otherwise it runs in 'prerelease' mode.

The installer images work differently, they use a metadata file that's embedded on the image somewhere, and the value in that depends on an arg passed to pungi during the compose process. So we decide whether the installer images behave as prerelease or final by the pungi command used.

*** This bug has been marked as a duplicate of bug 1888197 ***


Note You need to log in before you can comment on or make changes to this bug.