Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1888424 - Timezones are broken
Summary: Timezones are broken
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: glib2
Version: 33
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F33FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2020-10-14 19:56 UTC by Michael Catanzaro
Modified: 2020-10-15 20:56 UTC (History)
10 users (show)

Fixed In Version: glib2-2.66.1-3.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-15 20:56:12 UTC
Type: ---


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab GNOME/glib - issues 2215 0 None None None 2020-10-14 20:09:19 UTC
GNOME Gitlab GNOME/glib - issues 2224 0 None None None 2020-10-14 19:56:39 UTC

Description Michael Catanzaro 2020-10-14 19:56:04 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:80.0) Gecko/20100101 Firefox/80.0
Build Identifier: 

Timezones are broken, see https://gitlab.gnome.org/GNOME/glib/-/issues/2224.

Reproducible: Always

Comment 1 Fedora Blocker Bugs Application 2020-10-14 20:03:19 UTC
Proposed as a Freeze Exception for 33-final by Fedora user catanzaro using the blocker tracking app because:

 Top bar time is incorrect, timezone map in control center is broken... general basic functionality failure in apps that use glib.

Comment 2 Michael Catanzaro 2020-10-14 20:09:30 UTC
(In reply to Michael Catanzaro from comment #0)
> Timezones are broken, see https://gitlab.gnome.org/GNOME/glib/-/issues/2224.

Also https://gitlab.gnome.org/GNOME/glib/-/issues/2215. Two for one!

Comment 3 Adam Williamson 2020-10-14 20:19:07 UTC
2215 seems to be a Windows-specific bug?

2224 looks worrying, but...doesn't provide any info on the context in which this happens. When does the bug happen? To everyone all the time? I mean, my top bar time looks right, right now...with glib2-2.66.1-1.fc33.x86_64...was this introduced by something newer?

Comment 4 Michael Catanzaro 2020-10-14 20:25:24 UTC
(In reply to Adam Williamson from comment #3)
> 2215 seems to be a Windows-specific bug?

Well that caused a lot of confusion, but no, it seems to be affecting Linux too. I think the Windows users just assumed that glib wouldn't have a bug this serious on Linux :P

> 2224 looks worrying, but...doesn't provide any info on the context in which
> this happens. When does the bug happen? To everyone all the time? I mean, my
> top bar time looks right, right now...with glib2-2.66.1-1.fc33.x86_64...was
> this introduced by something newer?

It makes changing timezone impossible once a process starts. So if you open up gnome-control-center and try to change the timezone, you'll notice that panel is broken: https://gitlab.gnome.org/GNOME/glib/-/issues/2224#note_934734.

Chris was having some trouble related to automatic timezone changing the timezone as well, not sure about the full details there.

Comment 5 Adam Williamson 2020-10-14 21:09:16 UTC
Thanks for the details.

Comment 6 Chris Murphy 2020-10-14 21:16:13 UTC
I discovered this independently of the existing reports. It's been closed, but has screenshots that help clarify the visual manifestation of the bug.
https://gitlab.gnome.org/GNOME/gnome-desktop/-/issues/174

Comment 7 Fedora Update System 2020-10-14 22:08:48 UTC
FEDORA-2020-a5131d7862 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-a5131d7862

Comment 8 Michael Catanzaro 2020-10-14 22:10:25 UTC
(In reply to Chris Murphy from comment #6)
> It's been closed,

It's just moved to a different component. If you click on the blue "Closed (moved)" label it will take you to the open bug. There's also some fine print in the issue history you can use to get to the open issue.

Comment 9 Adam Williamson 2020-10-15 16:20:19 UTC
+5 votes in https://pagure.io/fedora-qa/blocker-review/issue/174 , marking accepted.

Comment 10 Fedora Update System 2020-10-15 19:08:57 UTC
FEDORA-2020-a5131d7862 has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-a5131d7862`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-a5131d7862

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Fedora Update System 2020-10-15 20:56:12 UTC
FEDORA-2020-a5131d7862 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.