Bug 1888634 - selinux is preventing LXDE login
Summary: selinux is preventing LXDE login
Keywords:
Status: CLOSED DUPLICATE of bug 1886196
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Zdenek Pytela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-15 12:04 UTC by Mamoru TASAKA
Modified: 2020-10-15 15:55 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-15 15:55:06 UTC
Type: Bug


Attachments (Terms of Use)

Description Mamoru TASAKA 2020-10-15 12:04:59 UTC
Description of problem:
On rawhide, currently selinux-policy / selinux-policy-targeted prevents LXDE login.


Version-Release number of selected component (if applicable):
selinux-policy-3.14.7-5.fc34
selinux-policy-targeted-3.14.7-5.fc34
lxdm-0.5.3-17.D20161111gita548c73e.fc34.x86_64


How reproducible:
100%

Steps to Reproduce:
1. Install Fedora 33 LXDE spin, and fully upgrade to rawhide
2. reboot
3.

Actual results:
Cannot login to LXDE session. /var/log/messages contains AVC denial

Oct 15 20:26:21 localhost audit[821]: AVC avc:  denied  { transition } for  pid=821 comm="lxdm-session" path="/etc/lxdm/PreLogin" dev="sda2" ino=132232 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=process permissive=0
Oct 15 20:26:21 localhost audit[823]: AVC avc:  denied  { transition } for  pid=823 comm="lxdm-session" path="/etc/lxdm/PostLogin" dev="sda2" ino=132230 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=process permissive=0
Oct 15 20:26:21 localhost audit[820]: AVC avc:  denied  { transition } for  pid=820 comm="lxdm-session" path="/etc/lxdm/Xsession" dev="sda2" ino=132235 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=process permissive=0


Expected results:
Can login to LXDE session

Additional info:,
No problem with selinux-policy-targeted-3.14.6-28.fc33.noarch and selinux-policy-3.14.6-28.fc33.noarch

Comment 1 Zdenek Pytela 2020-10-15 12:21:07 UTC
Hi,

Please check the type of the reported Xsession and other files:

  ls -laZ /etc/X11/xinit/

Comment 3 Mamoru TASAKA 2020-10-15 12:39:40 UTC
For sure, I tried using the above LXDE Live spin image

[root@localhost-live ~]# ls -alZ /etc/X11/xinit/
total 36
drwxr-xr-x. 5 root root system_u:object_r:bin_t:s0 4096 Oct 14 05:39 .
drwxr-xr-x. 6 root root system_u:object_r:etc_t:s0 4096 Oct 14 05:39 ..
-rwxr-xr-x. 1 root root system_u:object_r:bin_t:s0 2321 Jul 30 17:42 Xclients
drwxr-xr-x. 2 root root system_u:object_r:bin_t:s0 4096 Jul 30 17:50 Xclients.d
-rwxr-xr-x. 1 root root system_u:object_r:bin_t:s0 1490 Jul 30 17:42 xinitrc
-rw-r--r--. 1 root root system_u:object_r:bin_t:s0 1870 Jul 30 17:42 xinitrc-common
drwxr-xr-x. 2 root root system_u:object_r:bin_t:s0 4096 Oct 14 05:39 xinitrc.d
drwxr-xr-x. 2 root root system_u:object_r:bin_t:s0 4096 Oct 14 05:39 xinput.d
lrwxrwxrwx. 1 root root system_u:object_r:bin_t:s0   26 Oct 14 05:39 xinputrc -> /etc/alternatives/xinputrc
-rwxr-xr-x. 1 root root system_u:object_r:bin_t:s0 3552 Jul 30 17:42 Xsession

Comment 4 Mamoru TASAKA 2020-10-15 12:42:59 UTC
Perhaps you need this

[root@localhost-live ~]# ls -alZ /etc/lxdm
total 48
drwxr-xr-x.   2 root root system_u:object_r:etc_t:s0  4096 Oct 15 08:27 .
drwxr-xr-x. 128 root root system_u:object_r:etc_t:s0 12288 Oct 15 08:35 ..
-rwxr-xr-x.   1 root root system_u:object_r:bin_t:s0    68 Aug 12 03:17 LoginReady
-rw-r-----.   1 root root system_u:object_r:etc_t:s0  1193 Oct 15 08:27 lxdm.conf
-rwxr-xr-x.   1 root root system_u:object_r:bin_t:s0    68 Aug 12 03:17 PostLogin
-rwxr-xr-x.   1 root root system_u:object_r:bin_t:s0    68 Aug 12 03:17 PostLogout
-rwxr-xr-x.   1 root root system_u:object_r:bin_t:s0    68 Aug 12 03:17 PreLogin
-rwxr-xr-x.   1 root root system_u:object_r:bin_t:s0    68 Aug 12 03:17 PreReboot
-rwxr-xr-x.   1 root root system_u:object_r:bin_t:s0    68 Aug 12 03:17 PreShutdown
-rwxr-xr-x.   1 root root system_u:object_r:bin_t:s0  1284 Aug 12 03:17 Xsession

Comment 5 Zdenek Pytela 2020-10-15 15:22:39 UTC
Thank you for the commands output and for the link, that should be enough for troubleshooting.

As I am not aware of any possibly related change in selinux-policy, I wonder what could have changed in lxdm or elsewhere in rawhide.

What is your kernel version?

Comment 6 Zdenek Pytela 2020-10-15 15:55:06 UTC
Closing this bz to continue in bz#1886196.

*** This bug has been marked as a duplicate of bug 1886196 ***


Note You need to log in before you can comment on or make changes to this bug.