Bug 1888654 - stap-server fails to start
Summary: stap-server fails to start
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: systemtap
Version: 33
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Frank Ch. Eigler
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-15 12:46 UTC by David Sastre Medina
Modified: 2021-05-10 14:35 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-10 14:35:18 UTC
Type: Bug


Attachments (Terms of Use)

Description David Sastre Medina 2020-10-15 12:46:15 UTC
Description of problem:

Executing a systemtap script is not possible:

# stap -L 'kernel.function("bpf_check")' 
Using a compile server.
Unable to find a suitable compile server.  [man stap-server]
No servers online to select from.
The kernel on your system requires modules to be signed for loading.
The module created by compiling your script must be signed by a systemtap compile-server.  [man stap-server]
--use-server was automatically selected in order to request compilation by a compile-server.

# systemctl restart stap-server.service 
Job for stap-server.service failed because the control process exited with error code.
See "systemctl status stap-server.service" and "journalctl -xe" for details.

# systemctl status stap-server.service 
● stap-server.service - Systemtap Compile Server
     Loaded: loaded (/usr/lib/systemd/system/stap-server.service; disabled; vendor preset: disabled)
     Active: failed (Result: exit-code) since Thu 2020-10-15 14:42:54 CEST; 2s ago
       Docs: man:stap-server(8)
    Process: 71070 ExecStart=/usr/bin/stap-server start -i (code=exited, status=1/FAILURE)
   Main PID: 71070 (code=exited, status=1/FAILURE)
        CPU: 88ms

Oct 15 14:42:54 shinchan.laptop.redhat.com systemd[1]: Starting Systemtap Compile Server...
Oct 15 14:42:54 shinchan.laptop.redhat.com stap-server[71070]: Starting stap-server -a "x86_64" -r "5.5.6-201.fc31.x86_64" -r "5.5.7-200.fc31.x86_64" -r "5.5.8-200.fc31.x86_64" -r "5.8.12-300.fc33.x86_64" -r "5.8.13-300.fc33.x86_64" -r "5>
Oct 15 14:42:54 shinchan.laptop.redhat.com stap-server[71156]: Error initializing NSS for dbm:/var/lib/stap-server/.systemtap/ssl/server
Oct 15 14:42:54 shinchan.laptop.redhat.com stap-server[71156]: (-8015 SEC_ERROR_LEGACY_DATABASE) The certificate/key database is in an old, unsupported format.
Oct 15 14:42:54 shinchan.laptop.redhat.com stap-server[71156]: Unable to generate certificate
Oct 15 14:42:54 shinchan.laptop.redhat.com stap-server[71070]: Failed to make certificates (stap-server .systemtap/ssl/server/stap.cert)
Oct 15 14:42:54 shinchan.laptop.redhat.com systemd[1]: stap-server.service: Main process exited, code=exited, status=1/FAILURE
Oct 15 14:42:54 shinchan.laptop.redhat.com systemd[1]: stap-server.service: Failed with result 'exit-code'.
Oct 15 14:42:54 shinchan.laptop.redhat.com systemd[1]: Failed to start Systemtap Compile Server.

Version-Release number of selected component (if applicable):

# rpm -qa | grep systemtap
systemtap-sdt-devel-4.4-0.20200805git82b8e1a07.fc33.x86_64
systemtap-client-4.4-0.20200805git82b8e1a07.fc33.x86_64
systemtap-devel-4.4-0.20200805git82b8e1a07.fc33.x86_64
systemtap-runtime-4.4-0.20200805git82b8e1a07.fc33.x86_64
systemtap-4.4-0.20200805git82b8e1a07.fc33.x86_64
systemtap-server-4.4-0.20200805git82b8e1a07.fc33.x86_64

How reproducible:

Reproducible

Steps to Reproduce:

1. Intall systemtap packages, specifically the stap-server
2. start the server using `systemctl start stap-server`
3. Check the error on the journal using `journalctl -xe`

Actual results:

The stap-server fails to start

Expected results:

The stap-server can be started correctly

Additional info:

# ausearch -m avc -ts today
<no matches>

Comment 1 Frank Ch. Eigler 2020-11-30 19:08:10 UTC
fedora nss3 builds have disabled the DBM backend in libnss since version 3.56.0
We'll have to use sql: or whatnot.

See also https://sourceware.org/bugzilla/show_bug.cgi?id=23356 as the bug that
caused us to hard-code dbm:// in nsscommon.cxx.

Comment 2 Frank Ch. Eigler 2021-05-10 14:35:18 UTC
systemtap 4.5 includes a fix for this problem


Note You need to log in before you can comment on or make changes to this bug.