Bug 1888961 - anaconda part size=1 and --grow and --encrypted causes: An unknown error has occurred
Summary: anaconda part size=1 and --grow and --encrypted causes: An unknown error has ...
Keywords:
Status: CLOSED DUPLICATE of bug 1836269
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: python-blivet
Version: 8.2
Hardware: Unspecified
OS: Linux
low
low
Target Milestone: rc
: 8.1
Assignee: Blivet Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On: 1680013 1682561
Blocks: 1515824
TreeView+ depends on / blocked
 
Reported: 2020-10-16 15:34 UTC by Josef Kubin
Modified: 2021-09-06 15:28 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1680013
Environment:
Last Closed: 2020-10-19 09:03:19 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
log files from the virtual machine (14.35 MB, application/gzip)
2020-10-16 15:34 UTC, Josef Kubin
no flags Details

Description Josef Kubin 2020-10-16 15:34:50 UTC
Created attachment 1722117 [details]
log files from the virtual machine

+++ This bug was initially created as a clone of Bug #1680013 +++

Description of problem:

We are unable to install RHEL8.2 with the following ks.cfg
~~~
lang en_US
keyboard us
timezone America/New_York --isUtc
rootpw redhat
#sshpw --username=root redhat
#platform x86, AMD64, or Intel EM64T
reboot
text
cdrom
eula --agreed
bootloader --location=mbr --append="rhgb quiet crashkernel=auto"
zerombr
clearpart --all --initlabel --drives=/dev/nvme0n1

# Disk partitioning information
part /boot/efi --fstype=efi --size=512
part /boot --fstype=ext4 --size=512
part pv.0 --size=1 --grow --ondisk=/dev/nvme0n1 --encrypted --cipher=aes-cbc-essiv:sha256 --passphrase=redhat --luks-version=luks1
volgroup rootvg pv.0
logvol / --size=5000 --fstype=ext4 --vgname=rootvg --name=root

auth --passalgo=sha512 --useshadow
selinux --permissive
firewall --disabled
firstboot --disable
%packages
@^minimal-environment
kexec-tools
%end
~~~

If we change the option from "--size=1" to "--size=16", the installation works:
~~~
part pv.0 --size=16 --grow --ondisk=/dev/nvme0n1 --encrypted --cipher=aes-cbc-essiv:sha256 --passphrase=redhat --luks-version=luks1
~~~

Version-Release number of selected component (if applicable):
anaconda 29.19.2.17
rhel-8.2-x86_64-dvd.iso (from https://access.redhat.com/downloads/content/479/ver=/rhel---8/8.2/x86_64/product-software)

How reproducible:
always

Steps to Reproduce:

~~~
$ qemu-img create test.img 20G
~~~

rhel.sh
~~~
#!/bin/bash
qemu-system-x86_64 \
        -enable-kvm \
        -cpu host \
        -smp 2 \
        -m 4G \
        -boot d \
        -net nic \
        -net user,hostfwd=tcp::2222-:22 \
        -cdrom rhel-8.2-x86_64-dvd.iso \
        -rtc base=localtime \
        -drive id=drive_image1,if=none,aio=native,cache=none,file=test.img \
        -device nvme,id=image1,drive=drive_image1,serial=NVME_D001
~~~

Additional info:

All necessary log files are attached.

Comment 2 Vojtech Trefny 2020-10-19 09:03:19 UTC

*** This bug has been marked as a duplicate of bug 1836269 ***


Note You need to log in before you can comment on or make changes to this bug.