This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 188917 - xbase rpm does not build due to a compile error
xbase rpm does not build due to a compile error
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xbase (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2006-04-13 11:24 EDT by Prarit Bhargava
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-04 09:50:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to fix compile error in xbase (443 bytes, patch)
2006-04-13 11:24 EDT, Prarit Bhargava
no flags Details | Diff

  None (edit)
Description Prarit Bhargava 2006-04-13 11:24:22 EDT
Description of problem:

xbase does not compile due to a coding error.

Version-Release number of selected component (if applicable):
xbase-2.0.0

How reproducible: 100%

Steps to Reproduce:
1. rpmbuild --rebuild source.rpm or rpmbuild -bb spec.file
  
Actual results:

Build fails with:

/usr/lib/gcc/ia64-redhat-linux/4.1.0/../../../../include/c++/4.1.0/backward/backward_warning.h:32:2:
warning: #warning This file includes at least one deprecated or antiquated
header. Please consider using one of the 32 headers found in section 17.4.1.2 of
the C++ standard. Examples include substituting the <X> header for the <X.h>
header for C++ includes, or <iostream> instead of the deprecated header
<iostream.h>. To disable this warning use -Wno-deprecated.
/usr/src/redhat/BUILD/xbase-2.0.0/xbase/ntx.h:221: error: extra qualification
'xbNtx::' on member 'AllocKeyBufs'
make[1]: *** [xbexcept.lo] Error 1
make[1]: *** Waiting for unfinished jobs....
make[1]: *** [stack.lo] Error 1



Expected results:

Build should succeed.

Additional info: Patch attached.
Comment 1 Prarit Bhargava 2006-04-13 11:24:22 EDT
Created attachment 127713 [details]
Patch to fix compile error in xbase
Comment 2 Tom "spot" Callaway 2006-06-04 09:50:36 EDT
Fixed in 2.0.0-5

Note You need to log in before you can comment on or make changes to this bug.