Bug 1889192 - pkgconf-pkg-config points to non-exising file
Summary: pkgconf-pkg-config points to non-exising file
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pkgconf
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Neal Gompa
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-19 00:18 UTC by Rafal Wachol
Modified: 2020-10-23 22:14 UTC (History)
3 users (show)

Fixed In Version: pkgconf-1.7.3-5.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-23 22:14:32 UTC
Type: Bug


Attachments (Terms of Use)

Description Rafal Wachol 2020-10-19 00:18:18 UTC
Description of problem:

When running "pkg-config" on Fedora 33 it return an error:


/usr/bin/pkg-config: line 7: /usr/bin/x86_64-redhat-linux-pkg-config: No such file or directory



How reproducible:

1. Install pkgconf-pkg-config package
2. Invoke pkg-config in terminal


It should be an easy fix, since script points to

/usr/bin/x86_64-redhat-linux-pkg-config

but real path should be 

/usr/bin/x86_64-redhat-linux-gnu-pkg-config  // gnu part is missing

so it's the matter of changing /usr/bin/pkg-config file and add -gnu- or symlinking

Comment 1 Neal Gompa 2020-10-19 01:20:58 UTC
I'm confused how you don't have the right platform triple.

A relatively fresh installation of Fedora 33 indicates that the platform triple is correct:

ngompa@f33-kdedev ~> rpm -E "%_target_platform"
x86_64-redhat-linux-gnu

Comment 2 Rafal Wachol 2020-10-19 02:28:03 UTC
Thank you for fast reply. 

I downloaded and installed 33 today so it's fresh install. Might be regression? 

Is there any log that I can check to help track the issue?

Comment 3 Sergio Correia 2020-10-19 14:37:01 UTC
I ran into the same issue as well, but in a rawhide container. If redhat-rpm-config is installed, rpm -E "%_target_platform" returns the expected value, with the -gnu suffix, and the issue.

Comment 4 Sergio Correia 2020-10-19 14:38:17 UTC
*and the issue disappears. (completing comment #3)

Comment 5 Fedora Update System 2020-10-20 01:33:07 UTC
FEDORA-2020-1553536645 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-1553536645

Comment 6 Fedora Update System 2020-10-20 14:23:06 UTC
FEDORA-2020-1553536645 has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-1553536645`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-1553536645

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2020-10-23 22:14:32 UTC
FEDORA-2020-1553536645 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.