Bug 188925 - up-imapproxy does not compile due to missing #include
up-imapproxy does not compile due to missing #include
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: up-imapproxy (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Carlson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora-ia64 185729
  Show dependency treegraph
 
Reported: 2006-04-13 13:37 EDT by Prarit Bhargava
Modified: 2008-01-23 10:22 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-23 10:22:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix to add missing #include in up-imapproxy code (305 bytes, patch)
2006-04-13 13:37 EDT, Prarit Bhargava
no flags Details | Diff

  None (edit)
Description Prarit Bhargava 2006-04-13 13:37:31 EDT
Description of problem:

up-imapproxy does not compile due to missing #include

Version-Release number of selected component (if applicable):
up-imapproxy-1.2.4

How reproducible: 100%


Steps to Reproduce:
1. rpmbuild --rebuild source.rpm or rpmbuild -bb spec.file
  
Actual results:

Build fails with

src/imapcommon.c:377: error: 'MD5_DIGEST_LENGTH' undeclared (first use in this
function)
src/imapcommon.c:377: error: (Each undeclared identifier is reported only once
src/imapcommon.c:377: error: for each function it appears in.)
src/imapcommon.c:396: warning: pointer targets in passing argument 3 of
'EVP_DigestFinal' differ in signedness
src/imapcommon.c:658: warning: format '%d' expects type 'int', but argument 7
has type 'size_t'
src/imapcommon.c:377: warning: unused variable 'md5pw'
make: *** [src/imapcommon.o] Error 1
make: *** Waiting for unfinished jobs....
src/main.c: In function 'main':
src/main.c:605: warning: format '%d' expects type 'int', but argument 5 has type
'pthread_t'
src/main.c:630: warning: pointer targets in passing argument 3 of 'accept'
differ in signedness
src/main.c:659: warning: cast to pointer from integer of different size
src/main.c: In function 'SetBannerAndCapability':
src/main.c:957: warning: unused variable 'NumRef'
src/main.c: At top level:
src/main.c:160: warning: 'rcsId' defined but not used
src/main.c:161: warning: 'rcsSource' defined but not used
src/main.c:162: warning: 'rcsAuthor' defined but not used
error: Bad exit status from /var/tmp/rpm-tmp.3310 (%build)

Expected results:

Build should complete.

Additional info: Patch attached.
Comment 1 Prarit Bhargava 2006-04-13 13:37:31 EDT
Created attachment 127717 [details]
Fix to add missing #include in up-imapproxy code
Comment 2 Tim Jackson 2008-01-06 06:28:07 EST
This bug seems to have been fixed for a long time and therefore I think it
should be closed.
Comment 3 Doug Chapman 2008-01-23 10:22:45 EST
(In reply to comment #2)
> This bug seems to have been fixed for a long time and therefore I think it
> should be closed.

I agree, building cleanly for me now.  Closing it.

Note You need to log in before you can comment on or make changes to this bug.