Bug 1889270 - Installer complains about not enough vcpu for the baremetal flavor where generic bm flavor is being used
Summary: Installer complains about not enough vcpu for the baremetal flavor where gene...
Keywords:
Status: CLOSED DUPLICATE of bug 1889416
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.6.0
Assignee: Pierre Prinetti
QA Contact: David Sanz
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-19 08:39 UTC by weiwei jiang
Modified: 2020-10-19 15:55 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-19 15:55:29 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description weiwei jiang 2020-10-19 08:39:55 UTC
This bug was initially created as a copy of Bug #1878900

I am copying this bug because: 



Description of problem:

Installer complains about not enough vcpu for the baremetal flavor where generic bm flavor is being used

(shiftstack) [stack@chrisj-undercloud-osp13 ~]$ openshift-install --dir=ocpra create cluster --log-level=debug                                                                
DEBUG OpenShift Installer 4.6.0-0.nightly-2020-09-10-145837 
DEBUG Built from commit 1d3e041bcc50dee31138bb911da7e5fd4b101f7f 
DEBUG Fetching Metadata...                         
DEBUG Loading Metadata...                          
DEBUG   Loading Cluster ID...                      
DEBUG     Loading Install Config...                
DEBUG       Loading SSH Key...                     
DEBUG       Loading Base Domain...                 
DEBUG         Loading Platform...                  
DEBUG       Loading Cluster Name...                
DEBUG         Loading Base Domain...               
DEBUG         Loading Platform...                  
DEBUG       Loading Pull Secret...                 
DEBUG       Loading Platform...                    
FATAL failed to fetch Metadata: failed to load asset "Install Config": compute[0].platform.openstack.flavorName: Invalid value: "baremetal": Flavor did not meet the following minimum requirements: Must have minimum of 2 VCPUs, had 1 

when deploying on OpenStack Ironic nodes, it's not unusual to have a generic small baremetal flavor that catches all type of hardware including ones that hasn't been properly inspected.

This must be a new check on OCP 4.6 since I have not been getting that in OCP 4.5. It probably makes sense to not have that check with Baremetal nodes



Version-Release number of the following components:
OpenShift Installer 4.6.0-0.nightly-2020-09-10-145837

Comment 1 Pierre Prinetti 2020-10-19 15:55:29 UTC

*** This bug has been marked as a duplicate of bug 1889416 ***


Note You need to log in before you can comment on or make changes to this bug.