Bug 1889281 - wine compiled with mingw causes Deus Ex Mankind Divided to crash
Summary: wine compiled with mingw causes Deus Ex Mankind Divided to crash
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: mingw-gcc
Version: 32
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kalev Lember
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-19 09:15 UTC by roidal
Modified: 2020-10-24 13:01 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-24 13:01:33 UTC
Type: Bug


Attachments (Terms of Use)

Description roidal 2020-10-19 09:15:26 UTC
Description of problem:

The shipped wine-5.18 (and wine-5.19 from testing repo) causes
the game Deus Ex Mankind Divided to crash.

If wine get compiled without mingw it works fine.


Version-Release number of selected component (if applicable):

Fedora 32
wine-5.18/wine-5.19
DXVK 1.7.2
d3dcompiler_47 installes with winetricks
mesa 20.1.9

How reproducible:

Load a game in Deus Ex Mankind Divided.


Iam not sure if this is the right place to report it, but since mingw is involved seems to be right place.

There is also a Report on wine-bugzilla:
https://bugs.winehq.org/show_bug.cgi?id=50010

Comment 1 Richard W.M. Jones 2020-10-19 09:32:20 UTC
I'm confused by this bug.  Are you using the wine package from Fedora?
If so, what precise version?

You say "If wine get compiled without mingw it works fine", what does
that mean precisely?  What steps did you take (exactly) that made it work?

Comment 2 roidal 2020-10-19 09:42:13 UTC
Sorry for beeing unclear.

The game crashes if using the package provided by fedora.
This happens for both versions: 
  *) 5.18 from the fedora-updates repository
  *) 5.19 from the fedora-updates-testing repository

So i compiled wine myselfe on Fedora 32 using official sources from git://source.winehq.org/git/wine.git
and figured out that this problem does not happen anymore if the compilation is without mingw (eiter bei using "--without-mingw" for the configure-script, or do not provide that dependency at all).

Comment 3 roidal 2020-10-19 09:55:49 UTC
Steps to get it working

cloning the official wine-repository, fullfill dependencies, and checking out the wine-5.18 tag:

cd wine-git
git checkout wine-5.18
mkdir ../wine-5.18
cd ../wine-5.18
../wine-git/configure --enable-win64 --disable-tests --without-mingw
make

and then using the self-compiled wine-5.18 -> game runs fine

Comment 4 Sandro Mani 2020-10-24 13:01:33 UTC
Reported fixed upstream.


Note You need to log in before you can comment on or make changes to this bug.