Bug 188929 - xemacs RPM fails to build due to missing file
xemacs RPM fails to build due to missing file
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: xemacs (Show other bugs)
rawhide
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2006-04-13 14:20 EDT by Prarit Bhargava
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-01 17:01:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rpmbuild --rebuild xemacs.src.rpm output (345.99 KB, application/octet-stream)
2006-04-13 17:38 EDT, Prarit Bhargava
no flags Details

  None (edit)
Description Prarit Bhargava 2006-04-13 14:20:35 EDT
Description of problem:

xemacs RPM fails to build due to missing file

Version-Release number of selected component (if applicable):

xemacs-21.4.19-3.fc5.src.rpm

How reproducible: 100%


Steps to Reproduce:
1. rpmbuild --rebuild source.rpm or rpmbuild -bb spec.file
  
Actual results: 

Build fails with

File not found: /var/tmp/xemacs-21.4.19-3-root-root/usr/bin/ellcc

Expected results:

Build should not fail.

Additional info:
Comment 1 Ville Skyttä 2006-04-13 14:59:48 EDT
Based on the blocker bug set here, I'm guessing that this is on ia64.  I do not
have access to such a box nor is it currently a supported platform for Fedora
Extras, but if you can suggest a fix, I'd be glad to apply patches.  It would be
good if a better fix than just ignoring the absence of ellcc on ia64 would be found.

Please post a full build log, that might answer some questions.

Also, by the way, 4.fc5 as opposed to 3.fc5 is the current FE5 XEmacs package
revision.  And if you're adventurous, the FE devel branch contains a
work-in-progress XEmacs 21.5.26.
Comment 2 Prarit Bhargava 2006-04-13 16:56:29 EDT
I think you just solved the bug.  The issue is not that ellcc is "missing", it's
that there is no (Build)Requires line for it...

Patch a'comin' ...

P.
Comment 3 Prarit Bhargava 2006-04-13 17:36:11 EDT
D'oh ... ignore that.  I'm sleepy.  I'll attach a build log shortly.

P.
Comment 4 Prarit Bhargava 2006-04-13 17:38:32 EDT
Created attachment 127730 [details]
rpmbuild --rebuild xemacs.src.rpm output

As requested, an output of the rpmbuild ...
Comment 5 Ville Skyttä 2006-04-14 05:45:49 EDT
Ok, I think I got it fixed in CVS, 21.4.19-5.  Will not push a rebuild solely
for this because ia64 is not a supported FE platform, but the changes will be in
the next FE5 package revision whenever that happens.

In the meantime, please update your SRPM to the latest published one
(21.4.19-4.fc5, yours is 3.fc5) and try this patch on top of it:
http://cvs.fedora.redhat.com/viewcvs/rpms/xemacs/FC-5/xemacs.spec?r1=1.22&r2=1.23&root=extras&makepatch=1&diff_format=u
Comment 7 Prarit Bhargava 2006-10-05 10:59:54 EDT
Still not building in FC ....
Comment 8 Ville Skyttä 2006-10-09 01:55:04 EDT
(In reply to comment #7)
> Still not building in FC ....

You mean FC5, right?  Have you tested with the patch in comment 6?
Comment 9 Ville Skyttä 2007-09-01 16:35:38 EDT
Prarit, any news about this?
Comment 10 Prarit Bhargava 2007-09-01 17:01:47 EDT
.... This is a year old :)  I haven't tried it in a long time.  Ville, I'll
close this out and reopen if necessary.

Note You need to log in before you can comment on or make changes to this bug.