Bug 1889296 - Should texlive-imakeidx Requires/Suggests texlive-splitindex?
Summary: Should texlive-imakeidx Requires/Suggests texlive-splitindex?
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: texlive
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-19 10:30 UTC by Stephan Bergmann
Modified: 2020-10-26 01:06 UTC (History)
3 users (show)

Fixed In Version: texlive-2020-28.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-26 01:06:08 UTC
Type: Bug


Attachments (Terms of Use)

Description Stephan Bergmann 2020-10-19 10:30:59 UTC
At least with texlive-imakeidx-svn42287-21.fc32.noarch, installing it does not care to also install texlive-splitindex.  But that LaTeX imakeidx package provides a splitindex option, and using that option apparently requires texlive-splitindex and its /usr/bin/splitindex, and can silently fail to generate indexes if the latter is missing.

For confusion caused by this, see the comments at <https://github.com/cplusplus/draft/commit/47fa06efaee7cbc41e23b2b99721b755439fb3f6> "[index] Use LaTeX package 'imakeidx' to allow for more indices."  (Which uses that imakeidx splitindex option at <https://github.com/cplusplus/draft/commit/47fa06efaee7cbc41e23b2b99721b755439fb3f6#diff-f996668df88a56f464ddc43a33b03b6da4ca6c4ca68bfcb3fcae7adc0f5bf0d6R27>).)

Would it make sense to add a corresponding Requires or at least Suggests?

Comment 1 Tom "spot" Callaway 2020-10-19 22:54:27 UTC
Recommends seems like the right balance (Suggests are ignored by dnf). I'm making this change in Fedora 33+, I'm reluctant to push an update for Fedora 32 just for this because of the high cost of doing a texlive update to a released target.

Comment 2 Fedora Update System 2020-10-20 15:30:49 UTC
FEDORA-2020-e93acaad9e has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-e93acaad9e

Comment 3 Fedora Update System 2020-10-21 21:32:02 UTC
FEDORA-2020-e93acaad9e has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-e93acaad9e`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-e93acaad9e

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 4 Fedora Update System 2020-10-26 01:06:08 UTC
FEDORA-2020-e93acaad9e has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.