Bug 1889304 - [OSP] Installer always creates glance images with qcow2 disk format
Summary: [OSP] Installer always creates glance images with qcow2 disk format
Keywords:
Status: CLOSED DUPLICATE of bug 1882649
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.7
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.7.0
Assignee: Mike Fedosin
QA Contact: David Sanz
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-19 10:41 UTC by Mike Fedosin
Modified: 2020-10-19 11:00 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-19 11:00:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift installer pull 4279 None open Bug 1889304: Determine Glance disk format based on file extension 2020-10-19 10:54:34 UTC

Description Mike Fedosin 2020-10-19 10:41:01 UTC
Version: 4.7

Platform: OpenStack IPI

What happened?

When users want to create a Glance image for RHCOS with `clusterOSImage` option, the installer always sets qcow2 disk format regardless of the local file extension. Sometimes it's required to set `raw` format, if the file extension is `raw`.

What did you expect to happen?

If custom image extension is `raw` (i.e. rhcos-46.82.202010011740-0-openstack.x86_64.raw) the installer should set `raw` disk format instead of qcow2.

Comment 1 Mike Fedosin 2020-10-19 11:00:39 UTC

*** This bug has been marked as a duplicate of bug 1882649 ***


Note You need to log in before you can comment on or make changes to this bug.