Bug 1889349 - fish setting for nano-default-editor is unremovable (usage of universal variable)
Summary: fish setting for nano-default-editor is unremovable (usage of universal varia...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nano
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kamil Dudka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F33FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2020-10-19 12:51 UTC by Neal Gompa
Modified: 2020-10-19 18:13 UTC (History)
5 users (show)

Fixed In Version: nano-5.3-4.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-19 18:13:06 UTC
Type: Bug


Attachments (Terms of Use)

Description Neal Gompa 2020-10-19 12:51:59 UTC
Description of problem:
The declaration of the EDITOR variable in the universal scope makes it persist past uninstallation and reboot, as fish records setting universal variables in a persistent state database for a user profile.

The EDITOR variable should *not* be set as a universal variable so that it can be removed easily.

Version-Release number of selected component (if applicable):
5.3-2.fc33

How reproducible:
Always

Steps to Reproduce:
1. Switch to fish
2. Uninstall nano-default-editor
3. echo $EDITOR

Actual results:
EDITOR is set to /bin/fish

Expected results:
EDITOR is unset

Additional info:

Comment 1 Fedora Update System 2020-10-19 12:52:40 UTC
FEDORA-2020-f4c0c2f406 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-f4c0c2f406

Comment 2 Fedora Blocker Bugs Application 2020-10-19 12:53:30 UTC
Proposed as a Freeze Exception for 33-final by Fedora user ngompa using the blocker tracking app because:

 This fixes behavior of the $EDITOR variable for fish shell users to behave as we document it to be.

Comment 3 Geoffrey Marr 2020-10-19 17:27:24 UTC
Discussed during the 2020-10-19 blocker review meeting: [0]

The decision to classify this bug as an "AcceptedFreezeException (Final)" was made as it is a noticeable issue that cannot be fixed with an update.

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2020-10-19/f33-blocker-review.2020-10-19-16.01.txt

Comment 4 Fedora Update System 2020-10-19 18:13:06 UTC
FEDORA-2020-f4c0c2f406 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.