Bug 1889428 - Fedora 32 Workstation - clean install - no bluetooth
Summary: Fedora 32 Workstation - clean install - no bluetooth
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 32
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-19 16:15 UTC by Brian McCarthy
Modified: 2020-10-20 19:04 UTC (History)
19 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-20 19:04:35 UTC
Type: Bug


Attachments (Terms of Use)
log as requested by above page (62.15 KB, text/plain)
2020-10-19 16:15 UTC, Brian McCarthy
no flags Details

Description Brian McCarthy 2020-10-19 16:15:49 UTC
Created attachment 1722655 [details]
log as requested by above page

Description of problem:

Installation on a Dell Latitude E7440 - bluetooth does not work - wifi does.

Googling for "qualcomm Atheros AR9485 Wireless Network Adapter " showed a few very old links about rebuilding after finding the drivers - but 1) can't find the drivers on the Dell site and 2) Rebuild the kernel? Really?

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install Fedora workstation on a dell latitude e7440 from live-USB stick
2. confirm bluetooth is not found
3. done

Actual results:

No bluetooth device is found

Expected results:

the on-board bluetooth device is found and can be used.


Additional info:

visiting this page:  

https://fedoraproject.org/wiki/How_to_debug_Bluetooth_problems

the attachment from the bug log (as descrived on that page) is below.

other info from commands listed on that page:


 sudo hciconfig 

returns nothing (page says hardware error)

sudo systemctl status bluetooth
● bluetooth.service - Bluetooth service
     Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)
     Active: active (running) since Mon 2020-10-19 11:28:17 EDT; 43min ago
       Docs: man:bluetoothd(8)
   Main PID: 5018 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 9418)
     Memory: 2.1M
        CPU: 33ms
     CGroup: /system.slice/bluetooth.service
             └─5018 /usr/libexec/bluetooth/bluetoothd -d

Oct 19 11:28:17 localhost.localdomain bluetoothd[5018]: src/adapter.c:read_commands_complete() kernel supports the set_blocked_keys op
Oct 19 11:28:17 localhost.localdomain bluetoothd[5018]: src/adapter.c:read_commands_complete() kernel supports exp features
Oct 19 11:28:17 localhost.localdomain bluetoothd[5018]: src/adapter.c:read_index_list_complete() Number of controllers: 0
Oct 19 11:28:17 localhost.localdomain bluetoothd[5018]: src/profile.c:register_profile() sender :1.75
Oct 19 11:28:17 localhost.localdomain bluetoothd[5018]: src/profile.c:create_ext() Created "Headset Voice gateway"
Oct 19 11:28:17 localhost.localdomain bluetoothd[5018]: src/profile.c:register_profile() sender :1.75
Oct 19 11:28:17 localhost.localdomain bluetoothd[5018]: src/profile.c:create_ext() Created "Headset unit"
Oct 19 11:28:17 localhost.localdomain bluetoothd[5018]: plugins/hostname.c:property_changed() static hostname: localhost.localdomain
Oct 19 11:28:17 localhost.localdomain bluetoothd[5018]: plugins/hostname.c:property_changed() pretty hostname:
Oct 19 11:28:17 localhost.localdomain bluetoothd[5018]: plugins/hostname.c:property_changed() chassis: laptop



UI still does not allow me to turn on bluetooth


sudo lspci
00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 0b)
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 0b)
00:14.0 USB controller: Intel Corporation 8 Series USB xHCI HC (rev 04)
00:19.0 Ethernet controller: Intel Corporation Ethernet Connection I218-LM (rev 04)
00:1b.0 Audio device: Intel Corporation 8 Series HD Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 1 (rev e4)
00:1c.3 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 4 (rev e4)
00:1c.4 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 5 (rev e4)
00:1d.0 USB controller: Intel Corporation 8 Series USB EHCI #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation 8 Series LPC Controller (rev 04)
00:1f.2 RAID bus controller: Intel Corporation 82801 Mobile SATA Controller [RAID mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 8 Series SMBus Controller (rev 04)
02:00.0 Network controller: Qualcomm Atheros AR9485 Wireless Network Adapter (rev 01)
03:00.0 SD Host controller: O2 Micro, Inc. SD/MMC Card Reader Controller (rev 01)

Comment 1 Flavio Leitner 2020-10-19 19:07:58 UTC
Reassigning to kernel.

Comment 2 Brian McCarthy 2020-10-20 19:04:35 UTC
please close this.  This specific laptop did not have bluetooth (it was provided by the docking station with a dongle when it was running windows)


Note You need to log in before you can comment on or make changes to this bug.