Bug 188945 - autofs4 in FC5 direct: seems to ignore auto.direct maps
autofs4 in FC5 direct: seems to ignore auto.direct maps
Status: CLOSED DUPLICATE of bug 206208
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeffrey Moyer
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-13 16:27 EDT by das_deniz
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-13 16:50:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
fc6t3 autofs direct invokes mount with bad option '-s' (1.72 KB, text/plain)
2006-09-22 11:11 EDT, das_deniz
no flags Details
fc6t3 autofs indirect (/net) mount also uses invalid option -- s (4.59 KB, text/plain)
2006-09-22 11:31 EDT, das_deniz
no flags Details

  None (edit)
Description das_deniz 2006-04-13 16:27:15 EDT
Description of problem:

Jeff i'm using a version of autofs of yours on rh9 -- autofs-4.1.3-124.i386.rpm
and your 2.4.20 kernel patch and things are great. thank you and Ian very much. 

also i understand there is a limitation of autofs direct for 'root' mounts
(directly to /) so instead we have a symlink on the host like this:

  cd /
  ln -s /sw .

and in our auto.master:
 
  /-          yp:auto.direct

and entries in auto.direct like this:

  /sw/local               -rw,soft,intr maanddm2-2:/fs12/swtools/tools
  /sw/local1              -rw,soft,intr maanddm2-2:/fs12/swtools/tools1
  /sw/local2              -rw,soft,intr maanddm2-2:/fs12/swtools/tools2

and when running we see related autofs procs:

root  2907  ... /usr/sbin/automount /- yp auto.direct
root  2981  ... /usr/sbin/automount --submount /sw yp auto.direct


HOWEVER, with FC5 and the same maps in the same networking env - this is not
working.

Version-Release number of selected component (if applicable):

autofs-4.1.4-16.2.2

How reproducible:

readily.
Comment 1 Jeffrey Moyer 2006-04-13 16:50:43 EDT
Edit /etc/sysconfig/autofs and set DISABLE_DIRECT=0.
Comment 2 das_deniz 2006-04-13 16:56:04 EDT
i feel so ... oblivious. sorry and thank you.
Comment 3 das_deniz 2006-04-13 18:14:57 EDT
also, one more thing for anyone looking up autofs direct issues - the link i was
mentioning to get around the root mount of 'blah' was wong. instead we have in
auto.misc:

  /misc/blah -options mount:/path

and have 

  cd /
  ln -s /misc/blah .
Comment 4 das_deniz 2006-09-21 10:17:59 EDT
and this has changed again in FC6 T3 ???
there is no DISABLE_DIRECT in /etc/sysconfig/autofs
and i do not see a similar option with 

  'strings /usr/sbin/automount | grep -i direct'
Comment 5 Ian Kent 2006-09-21 10:43:56 EDT
(In reply to comment #4)
> and this has changed again in FC6 T3 ???
> there is no DISABLE_DIRECT in /etc/sysconfig/autofs

This is not used in FC6, that is autofs v5 dorsn't require
that option. Direct mounts can't be disabled.

Ian

Comment 6 das_deniz 2006-09-21 13:34:06 EDT
Thank you for the prompt reply... if this is the case then the config described
above that i've been using since rh9 no longer works.

I can see the map is distributed via NIS/yp using 'ypcat -k auto.direct'
I have '/- yp:auto.direct' in /etc/autofs.master. note i also have
'/home yp:auto_home' and that UNDERSCORETODOT=1 in /etc/sysconfig/autofs.

I can no longer see the arguments to automount threads (used to be procs).
but i know that 'ls /sw/local' doesn't work - (the mount point *is* there)

  ls: /sw/local: No such file or directory


and there's no /var/log/messages entry to aid debug.
Comment 7 Ian Kent 2006-09-21 20:20:18 EDT
(In reply to comment #6)

Just to confirm, this is FC6 we are talking about?

> Thank you for the prompt reply... if this is the case then the config described
> above that i've been using since rh9 no longer works.

Yes the config has changed.
You should have one installed as a .rpmnew if you've modified
the original.
The defaults should be fine for your map.

> 
> I can see the map is distributed via NIS/yp using 'ypcat -k auto.direct'
> I have '/- yp:auto.direct' in /etc/autofs.master. note i also have
> '/home yp:auto_home' and that UNDERSCORETODOT=1 in /etc/sysconfig/autofs.

This should still work.
Any messages in the log?
Is the automount process running?

I'd recommend removing the "yp:" and ensuring that /etc/nsswitch.conf
has the entry "automount: files nis". But it should still work anyway.

> 
> I can no longer see the arguments to automount threads (used to be procs).
> but i know that 'ls /sw/local' doesn't work - (the mount point *is* there)

You can see the autofs mounts in /proc/mounts.
There is only one threaded process now.

> 
>   ls: /sw/local: No such file or directory
> 
> 
> and there's no /var/log/messages entry to aid debug.

It still logs error to syslog.
If you want more information then see
http://people.redhat.com/jmoyer
for syslog setup but add "--debug" to the OPTIONS variable
in the config.

Ian
Comment 8 das_deniz 2006-09-22 11:11:58 EDT
Created attachment 136946 [details]
fc6t3 autofs direct invokes mount with bad option '-s'
Comment 9 das_deniz 2006-09-22 11:31:23 EDT
Created attachment 136947 [details]
fc6t3 autofs indirect (/net) mount also uses invalid option -- s
Comment 10 Jeffrey Moyer 2006-09-22 11:39:13 EDT
Update util-linux and nfs-utils.  Also see bug #206208.

*** This bug has been marked as a duplicate of 206208 ***

Note You need to log in before you can comment on or make changes to this bug.