Bug 1889539 - Major graphics corruption on VMware Workstation and VMware Fusion with Plasma Desktop
Summary: Major graphics corruption on VMware Workstation and VMware Fusion with Plasma...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mesa
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-19 22:51 UTC by Neal Gompa
Modified: 2020-11-27 15:38 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-27 15:36:56 UTC
Type: Bug


Attachments (Terms of Use)
glxinfo output on VMware Workstation VM running Fedora 33 (85.15 KB, text/plain)
2020-11-03 17:51 UTC, Neal Gompa
no flags Details

Description Neal Gompa 2020-10-19 22:51:27 UTC
Description of problem:
When installing and running Fedora 33 KDE on VMware Workstation or VMware Fusion, I encounter major graphics corruption issues.

Version-Release number of selected component (if applicable):
5.19.5-4.fc33

How reproducible:
Always

Steps to Reproduce:
1. Boot Fedora 33 KDE
2. Click on the application menu

Actual results:
Lots of tearing and breakage in rendering the shell

Expected results:
Renders perfectly fine

Additional info:
I was pointed to this kwin merge request as a potential fix: https://invent.kde.org/plasma/kwin/-/merge_requests/364

Comment 1 Neal Gompa 2020-10-20 02:37:02 UTC
Unfortunately, local testing of the kwin merge request has not yielded positive results. Nor has changing the renderer from OpenGL 2.0 to either OpenGL 3.1 or XRender. In fact, while corruption was slightly reduced with OpenGL 3.1, it wasn't significantly so, and XRender made it *much* worse.

Comment 2 Neal Gompa 2020-11-03 17:46:32 UTC
In case it helps, the Mesa version on my system is version 20.2.1-2.fc33.

Comment 3 Neal Gompa 2020-11-03 17:51:46 UTC
Created attachment 1726327 [details]
glxinfo output on VMware Workstation VM running Fedora 33

I've attached glxinfo output on VMware VM running Fedora 33

Comment 4 Mikhail Shchemelev 2020-11-13 14:50:49 UTC
FWIW i see the difference in reproducibility across distributions.

For example issue does not seem to be present on openSuse Tumbleweed with:
 - Qt 5.15.1
 - Plasma 5.20.2 (earlier versions like 5.19 worked as well)
 - Mesa 20.2.1
 - kernel 5.9.1 (earlier versions worked as well)
 - open-vm-tools 11.2.0

Meanwhile corruption is present on Fedora 33 with:
 - Qt 5.15.1
 - Plasma BOTH 5.19 and 5.20 (from copr)
 - Mesa 20.2.2
 - Kernel 5.8.18 (and any other really)
 - open-vm-tools 11.2.0

Also i think the issue was already present at least in F32

Maybe there is a significant difference in patchsets for Plasma/Qt/Mesa/X11? 
Some patch that is present in openSuse that suppresses/fixes the issue?

Comment 5 Neal Gompa 2020-11-15 03:05:52 UTC
(In reply to Mikhail Shchemelev from comment #4)
> 
> Also i think the issue was already present at least in F32

It is not present in Fedora 32 at all, even now.

Comment 6 Mikhail Shchemelev 2020-11-15 10:02:32 UTC
(In reply to Neal Gompa from comment #5)
> (In reply to Mikhail Shchemelev from comment #4)
> > 
> > Also i think the issue was already present at least in F32
> 
> It is not present in Fedora 32 at all, even now.

Ah, you are right, i just retested it on a fresh F32 install, complete with updates from both official repos and from kde copr.

Then i tried partial upgrade towards F33:
 - Upgrading qt libs to 5.15 (glibc got upgraded as a dep) - does NOT trigger the issue
 - Upgrading mesa libs to 20.2 (systemd, dnf and some other base packages upgraded as a dep) - DOES trigger the issue

So i would assume it narrows it down to mesa in regards to my earlier patchset difference hypothesis.

Comment 7 Neal Gompa 2020-11-27 15:36:56 UTC
This is now fixed for me with the upgrade to Mesa 20.3, verified on both VMware Workstation and VMware Fusion.

ngompa@localhost ~> sudo dnf history info last
[sudo] password for ngompa: 
Transaction ID : 52
Begin time     : Fri 27 Nov 2020 10:25:26 AM EST
Begin rpmdb    : 2148:535590e030f898a62cef8fe06c2aa5e791c1cb3d
End time       : Fri 27 Nov 2020 10:25:37 AM EST (11 seconds)
End rpmdb      : 2148:67afe1431e2ff6704930469cc92c610de2dd89f3
User           : Neal Gompa <ngompa>
Return-Code    : Success
Releasever     : 33
Command Line   : --refresh -y upgrade
Comment        : 
Packages Altered:
    Upgrade  distribution-gpg-keys-1.45-1.fc33.noarch @updates
    Upgraded distribution-gpg-keys-1.44-1.fc33.noarch @@System
    Upgrade  firefox-83.0-8.fc33.x86_64               @updates
    Upgraded firefox-83.0-3.fc33.x86_64               @@System
    Upgrade  gnupg2-2.2.25-2.fc33.x86_64              @updates
    Upgraded gnupg2-2.2.24-1.fc33.x86_64              @@System
    Upgrade  gnupg2-smime-2.2.25-2.fc33.x86_64        @updates
    Upgraded gnupg2-smime-2.2.24-1.fc33.x86_64        @@System
    Upgrade  mesa-dri-drivers-20.2.3-1.fc33.x86_64    @updates
    Upgraded mesa-dri-drivers-20.2.2-1.fc33.x86_64    @@System
    Upgrade  mesa-filesystem-20.2.3-1.fc33.x86_64     @updates
    Upgraded mesa-filesystem-20.2.2-1.fc33.x86_64     @@System
    Upgrade  mesa-libEGL-20.2.3-1.fc33.x86_64         @updates
    Upgraded mesa-libEGL-20.2.2-1.fc33.x86_64         @@System
    Upgrade  mesa-libGL-20.2.3-1.fc33.x86_64          @updates
    Upgraded mesa-libGL-20.2.2-1.fc33.x86_64          @@System
    Upgrade  mesa-libgbm-20.2.3-1.fc33.x86_64         @updates
    Upgraded mesa-libgbm-20.2.2-1.fc33.x86_64         @@System
    Upgrade  mesa-libglapi-20.2.3-1.fc33.x86_64       @updates
    Upgraded mesa-libglapi-20.2.2-1.fc33.x86_64       @@System
    Upgrade  mesa-libxatracker-20.2.3-1.fc33.x86_64   @updates
    Upgraded mesa-libxatracker-20.2.2-1.fc33.x86_64   @@System
    Upgrade  mesa-vulkan-drivers-20.2.3-1.fc33.x86_64 @updates
    Upgraded mesa-vulkan-drivers-20.2.2-1.fc33.x86_64 @@System
    Upgrade  openssh-8.4p1-3.fc33.x86_64              @updates
    Upgraded openssh-8.4p1-2.fc33.x86_64              @@System
    Upgrade  openssh-clients-8.4p1-3.fc33.x86_64      @updates
    Upgraded openssh-clients-8.4p1-2.fc33.x86_64      @@System
    Upgrade  openssh-server-8.4p1-3.fc33.x86_64       @updates
    Upgraded openssh-server-8.4p1-2.fc33.x86_64       @@System
    Upgrade  zlib-1.2.11-23.fc33.x86_64               @updates
    Upgraded zlib-1.2.11-22.fc33.x86_64               @@System


Note You need to log in before you can comment on or make changes to this bug.