Bug 1889621 - openshift4-cnf-test | Nodes where PTP agent is running are not detected properly (ptp daemonset)
Summary: openshift4-cnf-test | Nodes where PTP agent is running are not detected prope...
Keywords:
Status: CLOSED DUPLICATE of bug 1889835
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: CNF Platform Validation
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Federico Paolinelli
QA Contact: Nikita
URL:
Whiteboard:
Depends On:
Blocks: 1889741
TreeView+ depends on / blocked
 
Reported: 2020-10-20 08:45 UTC by Alberto Losada
Modified: 2020-10-20 17:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1889741 (view as bug list)
Environment:
Last Closed: 2020-10-20 17:00:13 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Alberto Losada 2020-10-20 08:45:09 UTC
Description of problem:

PTP test did not pass because cnf-tests did not detect properly the number of nodes running PTP. 

Version-Release number of selected component (if applicable):

quay.io/openshift-kni/cnf-tests:latest

How reproducible:


Steps to Reproduce:
1. Configure the ptpOperatorConfig CRD to run only on a subset of nodes. For instance, nodes where the role label is equal to cnf-worker.
2. podman run -v $(pwd)/:/kubeconfig:Z -v $(pwd)/reports:/reports:Z -e KUBECONFIG=/kubeconfig/kubeconfig -e DISCOVERY_MODE=true quay.io/openshift-kni/cnf-tests:latest /usr/bin/test-run.sh /usr/bin/test-run.sh -ginkgo.focus="ptp"


Actual results:

• Failure [0.652 seconds]
[ptp]
/go/src/github.com/openshift-kni/cnf-features-deploy/vendor/github.com/openshift/ptp-operator/test/ptp/ptp.go:33
  PTP configuration verifications
  /go/src/github.com/openshift-kni/cnf-features-deploy/vendor/github.com/openshift/ptp-operator/test/ptp/ptp.go:38
    Should check that all nodes are running at least one replica of linuxptp-daemon [It]
    /go/src/github.com/openshift-kni/cnf-features-deploy/vendor/github.com/openshift/ptp-operator/test/ptp/ptp.go:61

    should be one instance per node
    Expected
        <int32>: 2
    to be ==
        <int>: 5


Expected results:

PASS since they are just two nodes selected to run the PTP agent.

Additional info:

The nodes where the PTP agent must run is configured in the ptpOperatorConfig CRD. As an example:

                apiVersion: ptp.openshift.io/v1
                kind: PtpOperatorConfig
                metadata:
                  name: default
                  namespace: openshift-ptp
                spec:
                  daemonNodeSelector:
                    node-role.kubernetes.io/worker-cnf: ""

Comment 1 Sebastian Scheinkman 2020-10-20 17:00:13 UTC

*** This bug has been marked as a duplicate of bug 1889835 ***


Note You need to log in before you can comment on or make changes to this bug.