Bug 188965 - R package build failure due to missing rpms
R package build failure due to missing rpms
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: R (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2006-04-13 18:56 EDT by Prarit Bhargava
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-14 09:46:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prarit Bhargava 2006-04-13 18:56:32 EDT
Description of problem:

R package fails to build/install due to missing texinfo-tex package.

Version-Release number of selected component (if applicable):

R-2.2.1-5.fc6.src.rpm

How reproducible: 1005


Steps to Reproduce:
1. rpmbuild --rebuild source.rpm or rpmbuild -bb spec.file
  
Actual results:

Build fails with warning:

error: Failed build dependencies:
        texinfo-tex is needed by R-2.2.1-5.ia64

Expected results:

Build should complete.

Additional info: I'm unsure if this is a bug or not -- IMO, all packages 
required to build a Fedora Extra should be in Extras ... but that might not
be canon with fedoraproject.
Comment 1 Tom "spot" Callaway 2006-04-14 09:46:41 EDT
Not just Fedora Extras, but also Fedora Core... which is where texinfo-tex resides.

The devel/ branch points to rawhide for its builds, if you don't use rawhide,
you won't have texinfo-tex in Core, but if you do, it's there.

Note You need to log in before you can comment on or make changes to this bug.