Bug 1889669 - Error "foreman-maintain packages is-locked --assumeyes failed!" in satellite.log while installing satellite.
Summary: Error "foreman-maintain packages is-locked --assumeyes failed!" in satellite....
Keywords:
Status: CLOSED DUPLICATE of bug 1881150
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Installer
Version: 6.8.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: 6.9.0
Assignee: Eric Helms
QA Contact: Jameer Pathan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-20 10:59 UTC by Jameer Pathan
Modified: 2020-11-02 21:03 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-02 21:03:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 31135 Normal Closed foreman-maintain package lock check indicates false failure 2020-12-02 12:30:55 UTC

Description Jameer Pathan 2020-10-20 10:59:45 UTC
Description of problem:
Error "foreman-maintain packages is-locked --assumeyes failed!" in satellite.log while installing satellite.

Version-Release number of selected component (if applicable):
- Satellite 6.8.0 snap 20

How reproducible:
Always

Steps to Reproduce:
1. Install Satellite
2. Check /var/log/foreman-installer/satellite.log file for errors.

Actual results:

[DEBUG 2020-10-20T06:20:47 main] Executing: foreman-maintain packages is-locked --assumeyes
[DEBUG 2020-10-20T06:20:49 main] Packages are not locked
[ERROR 2020-10-20T06:20:49 main] foreman-maintain packages is-locked --assumeyes failed! Check the output for error!
[DEBUG 2020-10-20T06:20:49 main] Hook /usr/share/foreman-installer/katello/hooks/pre_commit/09-version_locking.rb returned nil
[DEBUG 2020-10-20T06:20:49 main] Hook /usr/share/foreman-installer/katello/hooks/pre_commit/13-hiera.rb returned nil
[DEBUG 2020-10-20T06:20:49 main] Hook /usr/share/foreman-installer/katello/hooks/pre_commit/14-cdn_setting.rb returned nil
[ INFO 2020-10-20T06:20:49 main] All hooks in group pre_commit finished

Expected results:


Additional info:
- Satellite installation finishes successfully and I face no issue in using it.
- It's only that there is this ERROR message present in satellite.log

Comment 1 Eric Helms 2020-11-02 21:03:00 UTC

*** This bug has been marked as a duplicate of bug 1881150 ***


Note You need to log in before you can comment on or make changes to this bug.