Bug 18897 - grep expression backwords in rc.sysinit for raid devices
Summary: grep expression backwords in rc.sysinit for raid devices
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: noarch Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-11 15:20 UTC by Dan Egli
Modified: 2014-03-17 02:16 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-11 15:52:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dan Egli 2000-10-11 15:20:22 UTC
In the /etc/rc.d/rc.sysint script, there is a grep line that pulls each
raiddev line from the /etc/raidtab file. However, the grep line used (grep
"^raiddev") will return any lines that do NOT contain raiddev because the
karrat reverses the grep results. This will prevent any raid devices from
starting automatically from rc.sysinit, and thus preventing any  file
systems stored on those raid devices from automounting and forcing the user
to a repair filesystem prompt on EACH boot. 

To fix, simply remove the karrat from the first grep line (grep "raiddev")
and it works as it appears to have been designed to work.

Comment 1 Tim Waugh 2000-10-11 15:52:38 UTC
Outside of a class (like [a-z]), a caret matches the empty string at the
beginning of a line. (Inside a class it negates the sense of the class.)

So the expression should be correct already.


Note You need to log in before you can comment on or make changes to this bug.