Bug 1889714 - opm index export doesn't properly recreate graph using semver mode
Summary: opm index export doesn't properly recreate graph using semver mode
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.6
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: ---
Assignee: Ankita Thomas
QA Contact: Jian Zhang
URL:
Whiteboard:
: 1889716 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-20 12:53 UTC by Kevin Rizza
Modified: 2021-04-26 19:08 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-04-05 17:08:29 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Kevin Rizza 2020-10-20 12:53:07 UTC
Description of problem:

Currently, when using `opm index export` to backfill the index image back to the appregistry nested directory format, opm generates the set of bundles included in a package and pulls the csvs for each bundle into the directory. Since those bundles become the source of truth for all graph information, any mode that takes that source of truth away from the replaces chain in the set of csvs is lost. Instead, opm should respect the changes made to the graph defined in the index image and modify the exported manifests to generate a replaces graph that properly encapsulates the information generated by index add commands using semver and semver-skippatch modes.


Version-Release number of selected component (if applicable):

4.6

How reproducible:

Always

Steps to Reproduce:
1. Add a set of bundles that do not have `replaces` set in their csvs using `opm index add` to an index image
2. `opm index export` that index image

Actual results:

The csvs do not have replaces set, the graphs those bundles represent will not link all of the bundles down from latest version to oldest version.

Expected results:

Exported csvs have replaces set properly so that the eventual app-registry blob can be unpacked by a cluster at runtime with the correct graph as defined in the index image.

Comment 1 Kevin Rizza 2020-10-20 18:27:30 UTC
*** Bug 1889716 has been marked as a duplicate of this bug. ***

Comment 2 Luiz Carvalho 2020-10-21 19:42:29 UTC
Any estimation of when this will be ready?

Comment 3 Nick Hale 2020-10-23 17:22:34 UTC
This is assigned to be worked on in the upcoming sprint.

Comment 6 Ankita Thomas 2021-01-28 18:03:26 UTC
Moving this to low, this bug potentially affects the pipelines team but they have no immediate plans to switch to semver mode for index building. See https://docs.google.com/document/d/1GWUPp2CivPWvL0IWOndZu9WX48oNmd4Cp9nCkM0QkeM


Note You need to log in before you can comment on or make changes to this bug.