Bug 1889725 - asciidoc fails to build with Python 3.10
Summary: asciidoc fails to build with Python 3.10
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: asciidoc
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fabian Affolter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2020-10-20 13:10 UTC by Tomáš Hrnčiar
Modified: 2020-11-03 10:56 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-03 10:56:40 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github asciidoc asciidoc-py3 pull 151 None open Properly detect and compare Python version 3.10+ 2020-10-30 11:46:08 UTC

Description Tomáš Hrnčiar 2020-10-20 13:10:20 UTC
asciidoc fails to build with Python 3.10.0a1.

This report is automated and not very verbose, but we'll try to get back here with details.

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01705809-asciidoc/

For all our attempts to build asciidoc with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/asciidoc/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Currently we do not know what is the reason of the failure.
 
python3 a2x.py -f manpage doc/a2x.1.txt
a2x: ERROR: "/builddir/build/BUILD/asciidoc-py3-986f99d743d0b6ddc2014bdc8dcfa991ab9b4863/asciidoc.py" --backend docbook -a "a2x-format=manpage"  --doctype manpage  --out-file "/builddir/build/BUILD/asciidoc-py3-986f99d743d0b6ddc2014bdc8dcfa991ab9b4863/doc/a2x.1.xml" "/builddir/build/BUILD/asciidoc-py3-986f99d743d0b6ddc2014bdc8dcfa991ab9b4863/doc/a2x.1.txt" returned non-zero exit status 1

make: *** [Makefile:110: doc/a2x.1] Error 1

Comment 1 Miro Hrončok 2020-10-30 11:14:33 UTC
I've tried to reproduce in mock to see the actual error:

<mock-chroot> bash-5.0$ "/builddir/build/BUILD/asciidoc-py3-9.0.2/asciidoc.py" --backend docbook -a "a2x-format=manpage"  --doctype manpage  --out-file "/builddir/build/BUILD/asciidoc-py3-9.0.2/doc/asciidoc.1.xml" "/builddir/build/BUILD/asciidoc-py3-9.0.2/doc/asciidoc.1.txt"
asciidoc: FAILED: Python 3.5 or better required


Seems like this is a bad version detection:

        if float(sys.version[:3]) < float(MIN_PYTHON_VERSION):
            message.stderr('FAILED: Python %s or better required' % MIN_PYTHON_VERSION)
            sys.exit(1)

Comment 3 Josef Ridky 2020-11-03 10:56:40 UTC
Fix is already in master branch.


Note You need to log in before you can comment on or make changes to this bug.