Bug 1889738 - /etc/multipath/conf.d is not copied correctly [NEEDINFO]
Summary: /etc/multipath/conf.d is not copied correctly
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: imgbased
Version: 4.3.11
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-4.3.12
: 4.3.12
Assignee: Nir Levy
QA Contact: peyu
URL:
Whiteboard:
Depends On: 1883195
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-20 13:37 UTC by Sandro Bonazzola
Modified: 2020-11-17 15:53 UTC (History)
11 users (show)

Fixed In Version: imgbased-1.1.16-0.1.el7ev
Doc Type: Bug Fix
Doc Text:
Previously, when performing an upgrade of the Red Hat Virtualization Host, the directory holding configuration files on the Manager was not created correctly. In this release, the directory is created correctly during an upgrade.
Clone Of:
Environment:
Last Closed: 2020-11-17 15:53:33 UTC
oVirt Team: Node
Target Upstream Version:
emarcus: needinfo? (nlevy)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:5131 None None None 2020-11-17 15:53:37 UTC
oVirt gerrit 111740 ovirt-4.3 MERGED osupdater: migrate_etc, copy folders to correct dirname 2020-11-15 15:27:39 UTC

Description Sandro Bonazzola 2020-10-20 13:37:06 UTC
This bug was initially created as a copy of Bug #1883195

I am copying this bug because: this needs to be backported to 4.3 EUS



Description of problem:
When upgrading oVirt, I noticed /etc/multipath/conf.d files were not copied correctly.

Instead of having the file in /etc/multipath/conf.d it ended up in /etc/multipath/conf.d/conf.d/


How reproducible:
Every upgade


Steps to Reproduce:
1. Put something in /etc/multipath/conf.d/
2. Upgrade oVirt
3. Files are now in /etc/multipath/conf.d/conf.d/

Expected results:
Should be in /etc/multipath/conf.d/


Additional info:

The cp is not correct, as it causes to copy the folder (and not the content of it) in the conf.d folder. So you end up with conf.d/conf.d/conf.d after upgrades :)

imgbased.log:2020-09-28 12:55:57,430 [DEBUG] (migrate_etc) Calling: (['cp', '-a', '-r', '/tmp/mnt.G9iGb///etc/multipath/conf.d', '/tmp/mnt.cM6Nj///etc/multipath/conf.d'],) {'close_fds': True, 'stderr': -2}

Comment 3 cshao 2020-11-09 01:57:25 UTC
Pending New Build.

Comment 4 Eli Marcus 2020-11-09 19:22:36 UTC
Hi Nir, 
please review this Doc Text for the errata: 

Previously, when performing an upgrade of the Red Hat Virtualization Host, the directory holding configuration files on the Manager was not created correctly.
In this release, the directory is created correctly during an upgrade.

Comment 5 peyu 2020-11-10 06:00:56 UTC
This bug has been resolved in redhat-virtualization-host-4.3.12-20201108.0.el7_9

Test versions:
RHVH: redhat-virtualization-host-4.3.12-20201108.0.el7_9
      redhat-virtualization-host-4.3.11-20200922.0.el7_9
RHVM: 4.3.11-0.1.el7

Test steps:
1. Install RHVH-4.3-20200922.1-RHVH-x86_64-dvd1.iso
2. Add host to RHVM
3. Create directories and files
   3.1 Create a directory under /etc and put a file in it. 
   3.2 Put a file under /etc
4. Setup local repos and point to "redhat-virtualization-host-4.3.12-20201108.0.el7_9"
5. Upgrade host via RHVM
6. After upgrade, check the directories and files created in step 3

Test results:
1. The directories and files created under /etc have been copied correctly.

So move the bug status to "VERIFIED"

Comment 7 errata-xmlrpc 2020-11-17 15:53:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Red Hat Virtualization Host (redhat-virtualization-host) 4.3.11 #1), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:5131


Note You need to log in before you can comment on or make changes to this bug.