Bug 188977 - python runs too slow on Fedora 5
python runs too slow on Fedora 5
Status: CLOSED DUPLICATE of bug 188327
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
5
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Mihai Ibanescu
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-14 01:35 EDT by njlegend
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-26 13:00:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description njlegend 2006-04-14 01:35:52 EDT
Description of problem:
when I use python to write 30M data to disk,it take's about 1 minute to finish
running,
but when I run it on redhat9, it take's only 5 seconds to finish running.
I think something is wrong with python on Fedora



Version-Release number of selected component (if applicable):
On Fedora,python is:
Python 2.4.2 (#1, Feb 12 2006, 03:59:46)
[GCC 4.1.0 20060210 (Red Hat 4.1.0-0.24)] on linux2
Type "help", "copyright", "credits" or "license" for more information.



How reproducible:
#b.py
import os,sys,time

f = open('a.txt','a+')
for i in range(2000000) :
  f.write('That is ' + str(i) + '\n')
f.close()


Steps to Reproduce:
1. time    python    b.py

2.
3.
  
Actual results:
On Fedora,
7.808u 3.056s 0:53.09 20.4%     0+0k 0+0io 9910pf+0w


Expected results:
On Redhat9
4.824u 0.180s 0:04.99 100.2%    0+0k 0+0io 0pf+0w


Additional info:
Comment 1 Jeremy Katz 2006-04-26 13:00:54 EDT

*** This bug has been marked as a duplicate of 188327 ***

Note You need to log in before you can comment on or make changes to this bug.