Bug 1889783 - Dev Console does not work with Service Binding Operator v0.2.0+ (4.5)
Summary: Dev Console does not work with Service Binding Operator v0.2.0+ (4.5)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.5.z
Assignee: divgupta
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On: 1883591
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-20 14:45 UTC by divgupta
Modified: 2020-11-05 12:47 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-05 12:46:58 UTC
Target Upstream Version:


Attachments (Terms of Use)
binder (399.00 KB, image/png)
2020-11-02 07:36 UTC, Gajanan More
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 6962 None closed Bug 1889783: Support ServiceBinding breaking api changes 2020-11-02 02:41:37 UTC
Red Hat Product Errata RHBA-2020:4325 None None None 2020-11-05 12:47:26 UTC

Description divgupta 2020-10-20 14:45:01 UTC
Description of problem:
Recently, Service Binding Operator (starting with v0.2.0) has changed API (CRD) that does not work with the current Dev Console (Topology View) of OpenShift (v4.5)

How reproducible: Always

Steps to Reproduce:
1.Create/import an application
2.Create a DB instance
3.Attempt any of the following :
    1. In Topology View, attempt to create a "Binding Connector" by dragging   arrow from the app to the DB -> The "binding connector" should be available, but is not.
    2. Create a ServiceBinding object to connect the app and DB, after the successful creation look in the Topology View -> the connection should be rendered, but isn't

Actual results:
binding connector is not available
binding connector is not rendered

Expected results:
binding connector should be available to be created if no binding exists
binding connector should be rendered (and interactive) if the binding exists


Additional info:

Comment 3 Gajanan More 2020-11-02 07:36:38 UTC
Created attachment 1725691 [details]
binder

Comment 4 Gajanan More 2020-11-02 07:38:08 UTC
Verified on: 4.5.17
Browser: Google Chrome
Marking this as verified

Comment 6 errata-xmlrpc 2020-11-05 12:46:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.17 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4325


Note You need to log in before you can comment on or make changes to this bug.