Bug 1889944 - spice-webdavd missing dependency on avahi-daemon.service
Summary: spice-webdavd missing dependency on avahi-daemon.service
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: phodav
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Marc-Andre Lureau
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-21 03:17 UTC by Diego Escalante Urrelo
Modified: 2020-10-21 08:54 UTC (History)
3 users (show)

Fixed In Version: phodav-2.5-2.fc33 phodav-2.5-2.eln104
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-21 08:50:42 UTC
Type: Bug


Attachments (Terms of Use)

Description Diego Escalante Urrelo 2020-10-21 03:17:54 UTC
Description of problem:
On a default Fedora Server installation, spice-webdavd will fail to start because avahi-daemon.service is not available, since `avahi` is not installed by default and spice-webdavd does not depend on avahi.


Version-Release number of selected component (if applicable):
2.4-2.fc33

How reproducible:
Always

Steps to Reproduce:
1. Install spice-webdavd
2. Try to start spice-webdavd

Actual results:
The service fails because of a missing avahi-daemon.service

Expected results:
Service starts

Comment 1 Fedora Update System 2020-10-21 08:38:39 UTC
FEDORA-2020-83899c42df has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 2 Marc-Andre Lureau 2020-10-21 08:42:49 UTC
reopening for f33

Comment 3 Fedora Update System 2020-10-21 08:50:42 UTC
FEDORA-2020-ceba59872d has been pushed to the Fedora ELN stable repository.
If problem still persists, please make note of it in this bug report.

Comment 4 Marc-Andre Lureau 2020-10-21 08:54:34 UTC
sigh.. and bodhi is unable to add the bug to the update..
Here it is.
https://bodhi.fedoraproject.org/updates/FEDORA-2020-dbd73d4976

let's leave that bug close then.


Note You need to log in before you can comment on or make changes to this bug.