Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 1890091

Summary: mysql imagestream test fails on ppc64le
Product: OpenShift Container Platform Reporter: Rafael Fonseca <rdossant>
Component: Multi-ArchAssignee: Rafael Fonseca <rdossant>
Status: CLOSED WORKSFORME QA Contact: Barry Donahue <bdonahue>
Severity: low Docs Contact:
Priority: low    
Version: 4.4CC: danili
Target Milestone: ---   
Target Release: 4.4.z   
Hardware: ppc64le   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-12-15 20:49:36 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1888004    
Bug Blocks:    

Description Rafael Fonseca 2020-10-21 11:33:32 UTC
Description of problem: "[image_ecosystem][mysql][Slow] openshift mysql image  Creating from a template [Top Level] [image_ecosystem][mysql][Slow] openshift mysql image  Creating from a template should instantiate the template [Suite:openshift]" fails


Version-Release number of selected component (if applicable): 4.4


How reproducible: always on P


Steps to Reproduce: run mentioned test on P


Actual results: Pod log

=> sourcing 20-validate-variables.sh ...
=> sourcing 25-validate-replication-variables.sh ...
=> sourcing 30-base-config.sh ...
---> 09:53:47     Processing basic MySQL configuration files ...
=> sourcing 60-replication-config.sh ...
=> sourcing 70-s2i-config.sh ...
---> 09:53:47     Processing additional arbitrary  MySQL configuration provided by s2i ...
=> sourcing 20-default-authentication-plugin.cnf ...
=> sourcing 40-paas.cnf ...
=> sourcing 50-my-tuning.cnf ...
---> 09:53:47     Starting MySQL server with disabled networking ...
---> 09:53:47     Waiting for MySQL to start ...
2020-10-21T09:53:47.773195Z 0 [Warning] [MY-011070] [Server] 'Disabling symbolic links using --skip-symbolic-links (or equivalent) is the default. Consider not using this option as it' is deprecated and will be removed in a future release.
2020-10-21T09:53:47.776273Z 0 [System] [MY-010116] [Server] /opt/rh/rh-mysql80/root/usr/libexec/mysqld (mysqld 8.0.21) starting as process 30
2020-10-21T09:53:47.858707Z 1 [System] [MY-013576] [InnoDB] InnoDB initialization has started.
---> 09:53:48     Waiting for MySQL to start ...
---> 09:53:49     Waiting for MySQL to start ...
---> 09:53:50     Waiting for MySQL to start ...
2020-10-21T09:53:50.924270Z 1 [System] [MY-013577] [InnoDB] InnoDB initialization has ended.
2020-10-21T09:53:51.595059Z 0 [System] [MY-011323] [Server] X Plugin ready for connections. Socket: /var/lib/mysql/mysqlx.sock
---> 09:53:51     Waiting for MySQL to start ...
2020-10-21T09:53:51.952030Z 0 [System] [MY-010229] [Server] Starting XA crash recovery...
2020-10-21T09:53:51.968988Z 0 [System] [MY-010232] [Server] XA crash recovery finished.
2020-10-21T09:53:51.983942Z 0 [ERROR] [MY-011947] [InnoDB] Cannot open '/var/lib/mysql/data/ib_buffer_pool' for reading: No such file or directory
---> 09:53:52     Waiting for MySQL to start ...
2020-10-21T09:53:52.953192Z 0 [Warning] [MY-010068] [Server] CA certificate ca.pem is self signed.
2020-10-21T09:53:52.954016Z 0 [System] [MY-013602] [Server] Channel mysql_main configured to support TLS. Encrypted connections are now supported for this channel.
2020-10-21T09:53:53.128900Z 0 [Warning] [MY-011810] [Server] Insecure configuration for --pid-file: Location '/var/lib/mysql/data' in the path is accessible to all OS users. Consider choosing a different directory.
2020-10-21T09:53:53.202376Z 0 [System] [MY-010931] [Server] /opt/rh/rh-mysql80/root/usr/libexec/mysqld: ready for connections. Version: '8.0.21'  socket: '/tmp/mysql.sock'  port: 0  Source distribution.
---> 09:53:53     MySQL started successfully
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
=> sourcing 40-datadir-action.sh ...
---> 09:53:53     Running datadir action: upgrade-warn
---> 09:53:53     MySQL server version check passed, both server and data directory are version 8.0.
=> sourcing 50-passwd-change.sh ...
---> 09:53:53     Setting passwords ...
mysql: [Warning] Using a password on the command line interface can be insecure.
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)
---> 09:53:54     WARNING: User userOKR does not exist in database. Password not changed.
mysql: [Warning] Using a password on the command line interface can be insecure.
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)

resulting in 

Readiness probe failed: sh: cannot set terminal process group (-1): Inappropriate ioctl for device sh: no job control in this shell ERROR 2003 (HY000): Can't connect to MySQL server on '127.0.0.1' (111)

Expected results: mysql pod runs successfully and the test passes


Additional info:

Comment 4 Dan Li 2020-10-21 13:19:19 UTC
Hi Rafael, can we add "UpcomingSprint" assuming that this but won't be resolved before the end of this week?

Comment 5 Dan Li 2020-10-23 12:32:03 UTC
Hi Rafael, can we add a "Target Release" to this bug based on your estimation? Right now it is considered "Untriaged" without a Target Release

Comment 6 Dan Li 2020-11-04 14:27:19 UTC
Hi @Rafael, I'm triaging this bug according to the new triage rules. Could you provide the following:

1. A "Priority" for this bug, as in how would you prioritize this bug within all the "Low" severity bug
2. Assign this bug with an "Assignee" within your CI team - will you be working on this bug or someone else?

Comment 7 Dan Li 2020-11-09 16:49:31 UTC
Hi Rafael, I'm assuming that this bug won't be resolved before the end of this sprint. If not, can we add "UpcomingSprint"?

Comment 8 Dan Li 2020-11-30 18:23:52 UTC
Hi Rafael, will this bug be resolved before the end of this sprint (Dec 5th)? If not, can we add "UpcomingSprint"?

Comment 9 Dan Li 2020-12-15 18:10:58 UTC
Hi Rafael, I am doing this exercise one week early because most people are out next week. Do you think this bug will be resolved before the end of this sprint (December 26th)? If not, I'd like to add "UpcomingSprint"

Comment 10 Rafael Fonseca 2020-12-15 20:49:36 UTC
It's not failing in CI currently, so I'm closing the bug.