Bug 1890328 - [3.11.z] CI uses outdated version of docker
Summary: [3.11.z] CI uses outdated version of docker
Keywords:
Status: CLOSED DUPLICATE of bug 1884001
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Test Infrastructure
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Steve Kuznetsov
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-21 21:45 UTC by Adam Kaplan
Modified: 2020-10-22 14:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-22 14:09:59 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Adam Kaplan 2020-10-21 21:45:21 UTC
Description of problem:

CI image for 3.11 extended_builds tests has an obsolete version of docker-1.3.11 installed. 

Version-Release number of selected component (if applicable): 3.11.z


How reproducible: Always


Steps to Reproduce:
1. Run the OCP 3.11 extended_builds suite
2. Review the log entry for the "Install docker" Ansible task.

Actual results:

Version docker-1.13.1-103.git7f2769b.el7.x86_64 is installed


Expected results:

Version docker-1.13.1-104 or higher is installed. This includes fixes to how docker processes symbolic links.


Additional info:


https://prow.ci.openshift.org/view/gcs/origin-ci-test/pr-logs/pull/25616/test_pull_request_origin_extended_builds_311/185/

https://gcsweb-ci.apps.ci.l2s4.p1.openshiftapps.com/gcs/origin-ci-test/pr-logs/pull/25616/test_pull_request_origin_extended_builds_311/185/build-log.txt

Comment 1 Steve Kuznetsov 2020-10-22 14:07:21 UTC
Scott, you're looking into this, right?

Comment 2 Scott Dodson 2020-10-22 14:09:59 UTC

*** This bug has been marked as a duplicate of bug 1884001 ***

Comment 3 Scott Dodson 2020-10-22 14:10:45 UTC
Yes, duped bug has details of my latest understanding.


Note You need to log in before you can comment on or make changes to this bug.