Bug 18904 - (SOUND ES1371)es1371 driver hangs machine after first use
(SOUND ES1371)es1371 driver hangs machine after first use
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-11 12:54 EDT by Rick Niles
Modified: 2008-08-01 12:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:38:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rick Niles 2000-10-11 12:54:28 EDT
I have been using my Ensoniq 1371 card with every version of 2.2 and lots
of pre-2.4 kernels and never had any problems.  With the kernel
shipped with RedHat 7.0, I can play one sound and then the machine
is totally and completely hung.  No kernel panic, no error message,
just freezes. I've got a ABIT BP6 with dual Celerons.

I've tried to use the ALSA drivers, but it seems I can't get those
to compile with either gcc (won't play nice with kernel) or kgcc
(header files screwed up).

Sorry to rant, but, I just don't understand how you
thought it made sense to ship a broken compiler with broken
header files. 6.2 just worked, why did you feel the need to
totally break the build tools for 7.0?  There is no value added.
I've always been a die-hard RedHat fan, but now I have no choice
but to look elsewhere for a working XFree86 4.0 distribution.
Comment 1 Alan Cox 2000-10-14 13:59:12 EDT
ALSA builds correctly with the kernel tree. I can vouch for that bit. I think I
know what the es1371
problem is, and its fixed in 2.2.18pre, it broke between 2.2.16->2.2.17 for a
small number of boards
Comment 2 Mike Pope 2001-03-21 00:05:12 EST
I can reproduce the hard lockup with my SB Vibra PCI 128.  The problem is
consistent across 2.2.16 through 2.2.19pre3 (latest I tried), and ALSA
0.9.0beta2.  The board identifies as:
  es1371: version v0.28 time 14:41:54 Dec 31 2000
  es1371: found chip, vendor id 0x1274 device id 0x1371 revision 0x06
  es1371: found es1371 rev 6 at io 0xb400 irq 11

I have tracked the lockup to a specific outl() in es1371.c, but got stuck there.
More detail available on request.
Comment 3 Mathieu de Naurois 2001-04-02 09:47:08 EDT
I get the same problem with the 2.2.18 kernel (from kernel.org) as well as with
the 2.4.2-0.1.28 kernel from Rawhide (and Redhat 7.1 beta) . Here is the result
of lspci:

00:00.0 Host bridge: VIA Technologies, Inc. VT8371 [KX133] (rev 02)
00:01.0 PCI bridge: VIA Technologies, Inc. VT8371 [KX133 AGP] 
00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev
22)
00:07.1 IDE interface: VIA Technologies, Inc. Bus Master IDE (rev 10)
00:07.2 USB Controller: VIA Technologies, Inc. UHCI USB (rev 10)
00:07.3 USB Controller: VIA Technologies, Inc. UHCI USB (rev 10)
00:07.4 Host bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev
30)
00:0d.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139 (rev 10)
00:0f.0 Multimedia audio controller: Ensoniq CT5880 [AudioPCI] (rev 02)
00:11.0 SCSI storage controller: Advanced Micro Devices [AMD] 53c974 [PCscsi]
(rev 10)
01:00.0 VGA compatible controller: ATI Technologies Inc 3D Rage Pro AGP 1X/2X
(rev 5c)

My machine is a 700 Mhz Athlon.

I also tried alsa drivers:

alsa 0.5.10b  WORKS
alsa 0.9.0beta2/beta3 CRASHES the system the same way, after about one second of
sound.

I can recompile my kernel and try patches if you sumbit me some.

Comment 4 Mathieu de Naurois 2001-04-04 05:07:18 EDT
In fact, there is a strange issue:

   if I first load the alsa 0.5.10b driver, play song, unload them,
replace them with the alsa 0.9.0beta2 or with the native driver,
 and load the new one without rebooting, everything works (I checked that the old driver were
unloaded (/proc/modules)). But after nextreboot, it crashes again.

It sounds like some card initialisation is missing.

By the way, may card is a SoundBlaster PCI 128
Comment 5 Mike Pope 2001-04-26 02:50:55 EDT
I can confirm that this problem is still around in 7.1 --- hard lockup on
anything that boils down to write(2) to the card.
Comment 6 Bugzilla owner 2004-09-30 11:38:50 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.