Bug 1890632 - systemd-xdg-autostart spewing into dmes log
Summary: systemd-xdg-autostart spewing into dmes log
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1891926 1893910 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-22 16:06 UTC by Simon Putt
Modified: 2020-12-10 01:15 UTC (History)
18 users (show)

Fixed In Version: systemd-247~rc2-1.fc34 systemd-246.7-2.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-12-10 01:15:22 UTC
Type: Bug


Attachments (Terms of Use)

Description Simon Putt 2020-10-22 16:06:48 UTC
Description of problem:

Perodicly the dmesg will log some spew from systemd-xdg-autostart-generator

Version-Release number of selected component (if applicable):

246.6-3 on fedora 33 beta updated to current date of 22nd oct 2020

How reproducible:

always


Steps to Reproduce:
1. just wait
2.
3.

Actual results:


[11434.473139] systemd-xdg-autostart-generator[32206]: /etc/xdg/autostart/org.freedesktop.problems.applet.desktop:91: Unknown key name 'DBusActivatable' in section 'Desktop Entry', ignoring.
[11434.475453] systemd-xdg-autostart-generator[32206]: Not generating service for XDG autostart app-gnome\x2dkeyring\x2dpkcs11-autostart.service, startup phases are not supported.
[11434.475470] systemd-xdg-autostart-generator[32206]: Not generating service for XDG autostart app-xdg\x2duser\x2ddirs-autostart.service, startup phases are not supported.

Expected results:

no output from systemd-xdg-autostart-generator??

Additional info:

Comment 1 Zbigniew Jędrzejewski-Szmek 2020-10-22 18:20:23 UTC
Yeah, this is already fixed upstream and will be gone in the next build.

Comment 2 Zbigniew Jędrzejewski-Szmek 2020-10-27 20:01:55 UTC
*** Bug 1891926 has been marked as a duplicate of this bug. ***

Comment 3 Henrique Martins 2020-11-01 15:33:51 UTC
And when is the next build going to be available? 

I have a cron job for user apache that runs every minute and generates lines like

 1x Unknown key name 'DBusActivatable' in section 'Desktop Entry'
 1x Queued start job for default target Main User Target.
 1x gnome-systemd-autostart-condition not found
 1x kde-systemd-start-condition not found
23x Not generating service for XDG autostart

for a total of 27 lines per run.  

As this runs 1440 times per day, it is getting pretty ridiculous.

Is there a way to silence those?

Comment 4 Zbigniew Jędrzejewski-Szmek 2020-11-03 10:06:06 UTC
*** Bug 1893910 has been marked as a duplicate of this bug. ***

Comment 5 Artem S. Tashkinov 2020-11-03 11:08:52 UTC
(In reply to Henrique Martins from comment #3)

> Is there a way to silence those?

You could try

1) sudo chmod -x /usr/lib/systemd/user-generators/systemd-xdg-autostart-generator

or

2) sudo mv /usr/lib/systemd/user-generators/systemd-xdg-autostart-generator /usr/lib/systemd/user-generators/systemd-xdg-autostart-generator.save

Comment 6 Zbigniew Jędrzejewski-Szmek 2020-11-17 15:53:23 UTC
Fixed in rawhide so far.

Comment 7 Edgar Hoch 2020-12-07 23:30:22 UTC
It is fine that it is fixed in a newer version, but it doesn't

Comment 8 Fedora Update System 2020-12-08 19:43:52 UTC
FEDORA-2020-3616681a70 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-3616681a70

Comment 9 Fedora Update System 2020-12-09 02:21:03 UTC
FEDORA-2020-3616681a70 has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-3616681a70`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-3616681a70

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2020-12-10 01:15:22 UTC
FEDORA-2020-3616681a70 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.