Bug 189075 - Sound no longer works since "upgrading"
Sound no longer works since "upgrading"
Status: CLOSED DUPLICATE of bug 178466
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
5
powerpc Linux
medium Severity high
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-15 11:51 EDT by Nigel Horne
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-16 02:14:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nigel Horne 2006-04-15 11:51:30 EDT
Description of problem:

Sound was fine on my laptop with FC4, but FC5 has broken it.



Version-Release number of selected component (if applicable):
system-config-soundcard-1.2.16-2

How reproducible:
Easily


Steps to Reproduce:
1. Install FC4
2. Upgrade to FC5
2.
3.
  
Actual results:

Starting system-config-soundcard now says:
amixer: Mixer attach default error: No such device
cat: /proc/asound/version: No such file or directory
cat: /proc/asound/modules: No such file or directory
cat: /proc/asound/pcm: No such file or directory

Expected results:
Should hear the same sample sound I did with FC4

Additional info:
[root@mac ~]# cat scsound.log
------- System Config Soundcard --------
Sat Apr 15 16:52:27 BST 2006

------- lspci --------
00:0b.0 Host bridge: Apple Computer Inc. UniNorth 1.5 AGP
00:10.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M6 LY
0001:10:0b.0 Host bridge: Apple Computer Inc. UniNorth 1.5 PCI
0001:10:17.0 Class ff00: Apple Computer Inc. KeyLargo Mac I/O (rev 03)
0001:10:18.0 USB Controller: Apple Computer Inc. KeyLargo USB
0001:10:19.0 USB Controller: Apple Computer Inc. KeyLargo USB
0001:10:1a.0 CardBus bridge: Texas Instruments PCI1410 PC card Cardbus
Controller (rev 02)
0002:24:0b.0 Host bridge: Apple Computer Inc. UniNorth 1.5 Internal PCI
0002:24:0e.0 FireWire (IEEE 1394): Agere Systems FW323
0002:24:0f.0 Ethernet controller: Apple Computer Inc. UniNorth GMAC (Sun GEM)
(rev 01)

------- lsmod --------
Module                  Size  Used by
radeon                124584  1
drm                    85560  2 radeon
nfsd                  258484  11
exportfs                6912  1 nfsd
lockd                  74292  2 nfsd
nfs_acl                 4224  1 nfsd
ppdev                  11364  0
autofs4                25124  1
sunrpc                188488  12 nfsd,lockd,nfs_acl
nls_utf8                2240  1
hfsplus                92068  1
dm_mirror              26100  0
dm_mod                 68192  1 dm_mirror
ipv6                  307364  12
lp                     15376  0
parport_pc             41460  0
parport                45936  3 ppdev,lp,parport_pc
ohci1394               42308  0
ieee1394              432896  1 ohci1394
ohci_hcd               25884  0
sungem                 38660  0
sungem_phy              9952  1 sungem
ext3                  156808  1
jbd                    78068  1 ext3

------- /etc/modprobe.conf --------
alias eth0 sungem
alias snd-card-0 snd-powermac
options snd-card-0 index=0
options snd-powermac index=0
remove snd-powermac { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-powermac
alias usb-controller ohci-hcd

------- /etc/asound.conf --------
# Generated by system-config-soundcard, do not edit by hand
defaults.pcm.card 0
defaults.pcm.card 0

------- aplay -l --------
aplay: device_list:222: no soundcards found...

------- amixer --------


------- /proc/asound/version --------


------- rpm -q alsa-lib --------
alsa-lib-1.0.11-3.rc2.2

------- rpm -q alsa-utils --------
alsa-utils-1.0.11-4.rc2

------- /proc/asound/modules --------


------- /proc/asound/pcm --------


------- system-config-soundcard --------

Wrong card index 0...
/usr/share/system-config-soundcard/soundcard.py:273: DeprecationWarning: use
gtk.ComboBox
  self.primarySubDeviceOptionMenu = gtk.OptionMenu()
/usr/share/system-config-soundcard/soundcard.py:308: GtkDeprecationWarning:
gtk.timeout_add is deprecated, use gobject.timeout_add instead
  self.timer = gtk.timeout_add (100, self.checkStatus, self)
/usr/share/system-config-soundcard/soundcard.py:548: GtkDeprecationWarning:
gtk.TRUE is deprecated, use True instead
  gtk.main()
ALSA lib pcm_hw.c:1305:(_snd_pcm_hw_open) Invalid value for card
aplay: main:547: audio open error: No such device
ALSA lib pcm_hw.c:1305:(_snd_pcm_hw_open) Invalid value for card
aplay: main:547: audio open error: No such device
Comment 1 Frank Arnold 2006-04-16 02:14:53 EDT
Thank you for the bug report. This particular bug has already been reported
into our bug tracking system, but please feel free to report any further
bugs you find.

*** This bug has been marked as a duplicate of 178466 ***

Note You need to log in before you can comment on or make changes to this bug.