Bug 189102 - K3b not finding SCSI drives
K3b not finding SCSI drives
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: k3b (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-16 03:42 EDT by Colin Ager
Modified: 2008-05-06 11:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 11:47:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Colin Ager 2006-04-16 03:42:28 EDT
Description of problem:
K3b does not find either of my SCSI DVD drives. It worked OK on FC3 and both
drives are accessible from the KDE desktop. Cdrecord also works OK.



Version-Release number of selected component (if applicable):


How reproducible:Every time


Steps to Reproduce:
1.Run K3b
2.
3.
  
Actual results:Splash screen appears and hangs for several mins. Eventually main
K3b screen appears but on looking in settings no drives have been found and it
is not possible to set them manually(on /dev/scd0 and /dev/scd1)


Expected results:Working system


Additional info:DVD writer is an IDE device connected to the SCSI bus through an
Acard SCSI to IDE adaptor. Reader is SCSI device 
/Var/log/Messages has comments about No/Incomplete CDB sent to device plus lots
of additionl lines which repeat several times
Comment 1 Harald Hoyer 2006-04-18 06:43:58 EDT
which k3b version?
Comment 2 Colin Ager 2006-04-18 15:43:27 EDT
(In reply to comment #1)
> which k3b version?

Originally v. 0.12.10. Have now used yum to upgrade to v. 0.12.14-0.fc5.2 with
the same result
Comment 3 Colin Ager 2006-04-21 05:03:45 EDT
Does this problem have a connection with that on k3b.org  email archive
2006-04-08  "k3b & SCSI devices on 2,6,16" .

 k3b worked with my drives on FC3 as I used it to burn the iso from the Fedora
website which I then used to update to FC5
Comment 4 Colin Ager 2006-07-05 11:33:26 EDT
In case anyone is still interested I reorganised the SCSI DVD writer as a native
IDE version which was detected and was then able to burn DVDs.

K3b still couldn't see the SCSI DVD reader. Yesterday I used Yum to update K3b
to the latest version and it now finds the reader! I will have to re-install the
SCSI incarnation of the writer to see if it can now find that but I dont know
when I wll get round to that.
Colin
Comment 5 Colin Ager 2006-07-10 10:29:13 EDT
I have now tried using the new version(0.12.15) but although it now finds the
SCSI DVD reader it will not read from it from within K3b. Trying to read disk
eventually causes Linux system to lock up requiring re-boot to recover. DVD
reader works normally from a desktop link
Comment 6 Thomas J Pinkl 2006-09-06 15:31:03 EDT
I have a similar problem.  I have an old SCSI CD-RW drive, a Yamaha CRW6416S.
k3b lists it as a read-only device.  I don't see any way to configure k3b to 
tell it differently. 

Version info:

  k3b 0.12.15-0.FC5.1
  kernel 2.6.17-1.2174_FC5
Comment 7 Bug Zapper 2008-04-03 22:39:21 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 8 Bug Zapper 2008-05-06 11:47:41 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.