Bug 189109 - Output of yum cannot be redirected to a file
Output of yum cannot be redirected to a file
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-16 06:26 EDT by Graham Leggett
Modified: 2014-01-21 17:53 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-19 16:47:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Graham Leggett 2006-04-16 06:26:55 EDT
An attempt to do this fails:

[root@gatekeeper rpm]# yum update > /tmp/out 2>&1  &
[1] 29203

Nothing is written to /tmp/out, so there is no clear indication that yum is
doing anything.

The only way to kill yum is with -9.
Comment 1 Jeremy Katz 2006-04-19 16:47:05 EDT
This works for me here.  You may be hitting the point where it prompts and it's
not flushing the output.  Try using yum -y.

Note You need to log in before you can comment on or make changes to this bug.