Bug 1891532 - openshift-object-counts quota is not dynamically updating as the resource is deleted.
Summary: openshift-object-counts quota is not dynamically updating as the resource is ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-controller-manager
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.z
Assignee: Lukasz Szaszkiewicz
QA Contact: zhou ying
URL:
Whiteboard:
Depends On: 1891527
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-26 14:46 UTC by Lukasz Szaszkiewicz
Modified: 2021-01-13 18:14 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1891527
Environment:
Last Closed: 2021-01-13 18:14:32 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-policy-controller pull 49 0 None closed Bug 1891532: openshift-object-counts quota is not dynamically updating as the resource is deleted 2021-01-11 10:47:46 UTC
Red Hat Product Errata RHBA-2021:0029 0 None None None 2021-01-13 18:14:45 UTC

Comment 2 Lukasz Szaszkiewicz 2020-11-16 09:48:16 UTC
I'm in the process of backporting the fix to the earlier version.

Comment 7 zhou ying 2020-12-04 12:54:17 UTC
Confirmed with latest payload , the issue has fixed:
[root@dhcp-140-138 ~]# oc get clusterversion 
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.4.0-0.nightly-2020-12-04-062247   True        False         10m     Cluster version is 4.4.0-0.nightly-2020-12-04-062247

[root@dhcp-140-138 ~]# oc project zhouy
Now using project "zhouy" on server "https://api.yinzhou1204-4.qe.devcluster.openshift.com:6443".
[root@dhcp-140-138 ~]# oc create quota test1 --hard=openshift.io/imagestreams=10
resourcequota/test1 created

[root@localhost ~]# oc describe quota test1
Name:                      test1
Namespace:                 zhouy
Resource                   Used  Hard
--------                   ----  ----
openshift.io/imagestreams  0     10
[root@localhost ~]# oc new-app httpd-example

[root@localhost ~]# oc describe quota test1
Name:                      test1
Namespace:                 zhouy
Resource                   Used  Hard
--------                   ----  ----
openshift.io/imagestreams  1     10

[root@localhost ~]# oc get is 
NAME            IMAGE REPOSITORY                                                       TAGS     UPDATED
httpd-example   image-registry.openshift-image-registry.svc:5000/zhouy/httpd-example   latest   38 seconds ago
ruby-ex         image-registry.openshift-image-registry.svc:5000/zhouy/ruby-ex                  
[root@localhost ~]# oc describe quota test1
Name:                      test1
Namespace:                 zhouy
Resource                   Used  Hard
--------                   ----  ----
openshift.io/imagestreams  2     10
[root@localhost ~]# oc delete all --all
pod "httpd-example-1-build" deleted
pod "httpd-example-1-deploy" deleted
pod "httpd-example-1-jl7ln" deleted
pod "ruby-ex-1-build" deleted
replicationcontroller "httpd-example-1" deleted
service "httpd-example" deleted
service "ruby-ex" deleted
deploymentconfig.apps.openshift.io "httpd-example" deleted
deploymentconfig.apps.openshift.io "ruby-ex" deleted
buildconfig.build.openshift.io "httpd-example" deleted
buildconfig.build.openshift.io "ruby-ex" deleted
imagestream.image.openshift.io "httpd-example" deleted
imagestream.image.openshift.io "ruby-ex" deleted
route.route.openshift.io "httpd-example" deleted
[root@localhost ~]# oc get is 
No resources found in zhouy namespace.
[root@localhost ~]# oc describe quota test1
Name:                      test1
Namespace:                 zhouy
Resource                   Used  Hard
--------                   ----  ----
openshift.io/imagestreams  0     10

Comment 10 errata-xmlrpc 2021-01-13 18:14:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.4.32 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:0029


Note You need to log in before you can comment on or make changes to this bug.