Bug 1891626 - [Release 4.6] Mutable LoadBalancer Scope
Summary: [Release 4.6] Mutable LoadBalancer Scope
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Routing
Version: 4.6.z
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.6.z
Assignee: Miciah Dashiel Butler Masters
QA Contact: Hongan Li
URL:
Whiteboard:
: 1892447 (view as bug list)
Depends On: 1891625
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-26 21:28 UTC by Dustin Row
Modified: 2020-12-07 13:54 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-30 16:45:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-ingress-operator pull 482 0 None closed [release-4.6] Bug 1891626: Support changing ingresscontroller load balancer scope 2021-01-28 17:29:30 UTC
Red Hat Product Errata RHBA-2020:5115 0 None None None 2020-11-30 16:45:53 UTC

Description Dustin Row 2020-10-26 21:28:30 UTC
Description of problem:
Ticket to track changes around changing the LoadBalancer Scope from immutable to mutable to support a patch of the IngressController CR. This BZ is for the backport to 4.6.z.

Additional info:
Ref: https://issues.redhat.com/browse/NE-172
PR: https://github.com/openshift/cluster-ingress-operator/pull/472

Comment 1 Miciah Dashiel Butler Masters 2020-10-28 19:49:34 UTC
*** Bug 1892447 has been marked as a duplicate of this bug. ***

Comment 2 Miciah Dashiel Butler Masters 2020-11-14 00:50:53 UTC
We'll try to get this backport merged in the upcoming sprint.

Comment 3 Hongan Li 2020-11-16 09:55:50 UTC
verified with a cluster (4.6.0-0.ci.test-2020-11-16-084740-ci-ln-qmbvd9t) launched by cluster-bot and passed.

# oc -n openshift-ingress-operator patch ingresscontroller/default -p '{"spec":{"endpointPublishingStrategy":{"loadBalancer":{"scope":"Internal"}}}}' --type=merge
ingresscontroller.operator.openshift.io/default patched

Comment 7 errata-xmlrpc 2020-11-30 16:45:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.6 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:5115

Comment 8 Scott Dodson 2020-12-07 13:54:55 UTC
This was a feature backport and I don't believe we should ever set feature backports at high severity. Feature backports go in only once we've cleared the critical period immediately after GA and have enabled upgrades for everyone. Backporting this feature when we did has halted efforts to promote the upgrade.


Note You need to log in before you can comment on or make changes to this bug.