Bug 189163 - metaSendsEscape toggling doesn't work
metaSendsEscape toggling doesn't work
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xterm (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-17 15:05 EDT by Noah Liddle
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-24 09:41:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Noah Liddle 2006-04-17 15:05:14 EDT
Description of problem:

Red Hat has been patching /usr/share/X11/app-defaults/XTerm
in order to unset the eightBitInput resource. That is done
so that Meta combinations send an ESC prefix instead of actual
metacharacters. That is OK, but this particular resource can't
be toggled through xterm's Main Options menu, and overrides the most
natural option used to achive this goal, which is metaSendsEscape.
Actually, it makes toggling metaSendsEscape through the Main Options
menu uneffective.

While the objective of this patch is valid, the best way to achieve
it is through the metaSendsEscape resource. That way users will be
able to toggle it on the fly for situation where sending ESC is
not acceptable, e.g., VIM sessions.

Suggested solution:

Changing the

``
! Red Hat Defaults:
*VT100*eightBitInput: 0
''

excerpt to

``
! Red Hat Defaults:
*VT100*metaSendsEscape: 1
''

Which will result in just the benefits without the prejudice.

Version-Release number of selected component (if applicable):

XTerm(209)
Comment 1 Thomas E. Dickey 2006-06-26 20:40:45 EDT
Both metaSendsEscape and eightBitInput can be toggled via the main
menu.  Also metaSendsEscape can be toggled via escape sequence.
To make parallel language here, I named the menu entry for eightBitInput
"Alt Sends Escape", and that's in patch #205.
Comment 2 Miroslav Lichvar 2006-08-24 09:41:01 EDT
Closing as NOTABUG, since eightBitInput can be toggled on the fly through the menu.

Note You need to log in before you can comment on or make changes to this bug.