Bug 189165 - GD temp files are not deleted
GD temp files are not deleted
Status: CLOSED DUPLICATE of bug 182719
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: php (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2006-04-17 15:17 EDT by Martin Sarsale
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-12-14 10:41:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

External Trackers
Tracker ID Priority Status Summary Last Updated
PHP Bug Tracker 30658 None None None Never

  None (edit)
Description Martin Sarsale 2006-04-17 15:17:22 EDT
From php tracker:

A temprorary file is create in gd.c line 1667.  This file is never
deleted.  Today I found 10 thousand files in /tmp on each server.

A comment on line 1720 says 

"the temporary file is automatically deleted" 

However, this is not the case.  I can't find any code anywhere that
would delete the tmp file.  I also checked the lastest cvs. 


I fixed the problem by rolling back to gd.c version which
works for me.
Comment 1 Joe Orton 2006-12-14 10:31:43 EST
Can you give a reproduction case for this temporary file leak?  A temporary file
leak was fixed in php-4.3.9-3.10 and later in the GIF output paths; perhaps this
was the bug in question.
Comment 2 Martin Sarsale 2006-12-14 10:37:58 EST
yes, I think it was
someone answer that in IRC like 8 months ago.
thanks anyway
Comment 3 Joe Orton 2006-12-14 10:41:43 EST
Thanks; sorry for the slow response.

*** This bug has been marked as a duplicate of 182719 ***

Note You need to log in before you can comment on or make changes to this bug.