Bug 1891716 - OVN cluster upgrade from 4.6.1 to 4.7 fails
Summary: OVN cluster upgrade from 4.6.1 to 4.7 fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.7
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.7.0
Assignee: Aniket Bhat
QA Contact: Anurag saxena
URL:
Whiteboard:
: 1892620 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-27 07:39 UTC by Yang Yang
Modified: 2021-02-24 15:29 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-02-24 15:28:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-network-operator pull 867 0 None closed Bug 1891716: Remove spurious label in the pod selector of the master daemonset. 2021-02-08 03:03:15 UTC
Red Hat Product Errata RHSA-2020:5633 0 None None None 2021-02-24 15:29:04 UTC

Description Yang Yang 2020-10-27 07:39:32 UTC
Description of problem:

OVN cluster upgrade from 4.6.1 to 4.7 fails

# oc get clusterversion 
NAME      VERSION   AVAILABLE   PROGRESSING   SINCE   STATUS 
version   4.6.1     True        True          5h      Unable to apply 4.7.0-0.nightly-2020-10-24-155529: the cluster operator network has not yet successfully rolled out 

Found this error in ovn pod log:
2020/10/27 06:48:39 could not apply (apps/v1, Kind=DaemonSet) openshift-ovn-kubernetes/ovnkube-master: could not update object (apps/v1, Kind=DaemonSet) openshift-ovn-kubernetes/ovnkube-master: DaemonSet.apps "ovnkube-master" is invalid: spec.selector: Invalid value: v1.LabelSelector{MatchLabels:map[string]string{"app":"ovnkube-master", "ovn-db-pod":"true"}, MatchExpressions:[]v1.LabelSelectorRequirement(nil)}: field is immutable

Version-Release number of selected component (if applicable):
4.7.0-0.nightly-2020-10-24-155529

How reproducible:
1/1

Steps to Reproduce:
1. Install an OVN cluster on 4.6.1
2. Upgrade it to 4.7

Actual results:
Upgrade fails

Expected results:
Upgrade succeeds

Additional info:

Comment 1 Yang Yang 2020-10-27 08:01:03 UTC
Must gather can be found in https://drive.google.com/file/d/18uqtifAgXEY24Z3Rta5v2qscjGfDOEg3/view?usp=sharing

Comment 3 Aniket Bhat 2020-11-09 19:42:35 UTC
*** Bug 1892620 has been marked as a duplicate of this bug. ***

Comment 4 Anurag saxena 2020-11-11 00:25:05 UTC
Upgrade worked fine for 4.6.3 -> 4.7.0-0.nightly-2020-11-10-163946

Comment 7 errata-xmlrpc 2021-02-24 15:28:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Moderate: OpenShift Container Platform 4.7.0 security, bug fix, and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2020:5633


Note You need to log in before you can comment on or make changes to this bug.