Bug 189179 - Use of Mysql with Proftpd
Use of Mysql with Proftpd
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: proftpd (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-17 17:08 EDT by Charles VINCHON
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.3.0-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-02 11:44:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles VINCHON 2006-04-17 17:08:57 EDT
Description of problem:
Proftpd can't run when mysql is configured with it

Version-Release number of selected component (if applicable):
1.3.0-0.2

How reproducible:


Steps to Reproduce:
1.Add mysql configuration to the proftpd.conf file
2.Run the proftpd daemon . The daemon won't run.
  
Actual results:
Impossible to connect to localhost ftp server

Expected results:
Proftpd with mysql should work

Additional info:
Maybe proftpd was not compiled with mysql support
Comment 1 Matthias Saou 2006-04-21 10:24:52 EDT
Indeed, it is compiled without mysql, postgresql and ldap. The reason was that
it used to mean adding dependencies to all of these libraries even if all that
was needed was a very basic ftp setup, so they could be optionally enabled at
build time.

Since recent proftpd releases support DSOs, I've recompiled 1.3.0 final with
mysql, postgresql and ldap modules in 3 sub-packages, which are optional. It
will be built for devel very soon, then backported to FC-5. All you'll need to
do is update your proftpd package and install the new proftpd-mysql sub-package.
Comment 2 Matthias Saou 2006-05-02 11:44:38 EDT
The new packages are now also built for FC-5 and should be available very soon.

Note You need to log in before you can comment on or make changes to this bug.