Bug 189183 - evolution update depends on wrong version of libpisock.so
evolution update depends on wrong version of libpisock.so
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-17 18:21 EDT by David Baron
Modified: 2007-11-30 17:11 EST (History)
14 users (show)

See Also:
Fixed In Version: 2.6.2-1.fc5.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-04 09:31:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Baron 2006-04-17 18:21:35 EDT
Description of problem:  The evolution update just released to FC5 updates
depends on the wrong version of libpisock.so

Version-Release number of selected component (if applicable):
evolution.i386 0:2.6.1-1.fc5.2

How reproducible: Always

Steps to Reproduce:
1. yum update
  
Actual results:
---> Package evolution.i386 0:2.6.1-1.fc5.2 set to be updated
...
--> Running transaction check
--> Processing Dependency: libpisock.so.8 for package: evolution
--> Finished Dependency Resolution
Error: Missing Dependency: libpisock.so.8 is needed by package evolution

Expected results:
no missing dependency

Additional info:
The previous evolution package required libpisock.so.9, not libpisock.so.8,
which is provided by the pilot-link package on FC5:

root@ridley Linux (0) ~ # rpm -q evolution
evolution-2.6.0-1
root@ridley Linux (0) ~ # rpm -q evolution --requires | grep pisoc
libpisock.so.9
root@ridley Linux (0) ~ # rpm -q --whatprovides libpisock.so.9
pilot-link-0.12.0-0.pre4.5.2.1
Comment 2 Bert DeKnuydt 2006-04-18 06:47:20 EDT
Installing pilot-link-0.11.8-14 and gnome-pilot-2.0.13-8 does not solve the
problem ...

rpm -Fvh gnome-pilot-2.0.13-8.i386.rpm pilot-link-0.11.8-14.i386.rpm 
error: Failed dependencies:
	libpisock.so.9 is needed by (installed) kdepim-3.5.1-1.2.i386

As this blocks _all_ other updates with a standard yum configuration, I consider
this pretty urgent and a security issue ...
Comment 3 Noa Resare 2006-04-18 08:12:22 EDT
Bert, have you tested updating kdepim (and any other pacakges that need
libpisock.so.9) to the their newest equivalents in devel?

I don't use kde myself but perhaps 

http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/Fedora/RPMS/kdepim-3.5.2-1.i386.rpm

works?
Comment 4 Bert DeKnuydt 2006-04-18 08:20:27 EDT
Tried that now ...

rpm -Fvh gnome-pilot-2.0.13-8.i386.rpm kdepim-3.5.2-1.i386.rpm
pilot-link-0.11.8-14.i386.rpm 
error: Failed dependencies:
	kdebase >= 6:3.5.2 is needed by kdepim-3.5.2-1.i386

I guess I could add kdebase etc. etc. ending up eating the full development tree.
I don't feel too confident to do that all over the place here ...
Comment 5 Noa Resare 2006-04-18 08:29:10 EDT
I see. Do you use kdepim frequently? If not you could always uninstall it. If
you do, you could recompile the old kdepim so that it links to the "new"
pilot-link package, or you could wait for the package maintainers to sort it out.
Comment 6 Bert DeKnuydt 2006-04-18 08:34:20 EDT
No, I never ever use it.  But ...

> yum erase kdepim
[...]
=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Removing:
 kdepim                  i386       6:3.5.1-1.2      installed          49 M
Removing for dependencies:
 kdesdk                  i386       3.5.1-1.2        installed          16 M
 kdevelop                i386       9:3.3.1-1.2      installed          34 M

And I do need kdevelop... Do I hear the word 'monolithic system' somewhere :)
Comment 7 Gilles Detillieux 2006-04-18 12:43:34 EDT
This is a problem on FC4 as well, and as Bert said in comment #2, this is (or at
the very least could soon become) a security risk, as it causes yum to abort
without installing any other available updates.
Comment 8 David Baron 2006-04-18 13:01:51 EDT
This seems to be fixed now for the FC5 case now that the kde*, gnome-pilot-* and
pilot-link* updates were pushed to updates.
Comment 9 Peter Ennis 2006-04-18 20:05:20 EDT
metacity-2.14.3-1.fc5.1.i 100% |=========================|  49 kB    00:00
---> Package metacity.i386 0:2.14.3-1.fc5.1 set to be updated
---> Downloading header for libgnome-devel to pack into transaction set.
libgnome-devel-2.14.1-1.f 100% |=========================|  16 kB    00:00
---> Package libgnome-devel.i386 0:2.14.1-1.fc5.1 set to be updated
--> Running transaction check
--> Processing Dependency: libpisock.so.8 for package: evolution
--> Finished Dependency Resolution
Error: Missing Dependency: libpisock.so.8 is needed by package evolution
[root@fc5 ~]#

just ran yum update, so it is not working yet here
Comment 10 Steve Isaacson 2006-04-18 22:13:05 EDT
It's still not working on a clean fc5 install nor on a fc4 to fc5 upgrade.
If a security patch is released noone will be able to receive the patch because
of this problem with evolution.

Because of that I think this bug merits a "HIGH" priority. But I am not allowed to
update the severity.

Is there a work-around? For example, can someone provide alternate yum.conf
files to use?
Comment 11 Noa Resare 2006-04-19 01:48:33 EDT
If it works or not depends on what updates mirror your yum client accesses. For
a few hours there was an internally inconsistent updates repo available from the
master server, that makes updates fail. It has been replaced with one that
doesn't have the problem but due to the inherent slowness of the updates
mirroring it is still available from mirrors, for example ftp.wsisiz.edu.pl.

So you basically have two options that I can think of ATM:

1) Wait for your mirror to catch the fixed verision of the updates repo
2) Find a mirror that is already updated

In theory, of course, no internally inconsistent repo would ever be released and
this problem would not occur. *blink, blink*
Comment 12 Leon Fauster 2006-04-19 05:00:02 EDT
Hello, libpisock.so.9 is needed by extras packages. Regards CM

[root@localhost]# rpm --test -ev pilot-link
libpisock.so.9 wird benötigt von (installiert) gnome-pilot-2.0.13-7.fc5.4.ppc
libpisock.so.9 wird benötigt von (installiert) evolution-2.6.0-1.ppc
libpisock.so.9 wird benötigt von (installiert) sylpheed-claws-2.1.0-1.fc5.ppc
Comment 13 kris van der merwe 2006-04-19 07:06:23 EDT
Its not only an update problem. Whilst trying to resolve the dependecies, I
accidently uninstalled Evolution.

Now I cant install  Evolution at all.  Basically Fedora 5 Evolution client
installs are disabled!!

Will this be fixed soon or should we download the evolution sources and try to
compile from scratch?
Comment 14 Steve Isaacson 2006-04-19 10:43:26 EDT
It works for me now with the standard, out-of-the-box yum mirrors.
Comment 15 Steve 2006-06-27 22:26:03 EDT
This is also a problem with kdepim-3.5.3, so the update to kde-3.5.3 fails,
rpm from planetmirror.com
Comment 16 Matthew Barnes 2006-06-28 17:19:45 EDT
Is this still an issue with recent FC5 updates?  I get:

# rpm -q evolution
evolution-2.6.2-1.fc5.5
# rpm -q evolution --requires | grep pisoc
libpisock.so.8
# rpm -q --whatprovides libpisock.so.8
pilot-link-0.11.8-12.4.fc5
Comment 17 David Juran 2006-08-04 09:31:02 EDT
This seems to be fixed with evolution-2.6.2-1.fc5.5 and kdepim-3.5.3-0.2.fc5 in FC5.

Note You need to log in before you can comment on or make changes to this bug.