Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 1891851

Summary: Clarify the error-message in case of incorrect cpu-type set to a cluster
Product: [oVirt] ovirt-engine Reporter: Beni Pelled <bpelled>
Component: GeneralAssignee: Lucia Jelinkova <ljelinko>
Status: CLOSED CURRENTRELEASE QA Contact: Polina <pagranat>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 4.4.3.8CC: ahadas, bugs, dfodor
Target Milestone: ovirt-4.4.6Keywords: ZStream
Target Release: 4.4.6.5Flags: pm-rhel: ovirt-4.4+
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: ovirt-engine-4.4.6.5 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-05-05 05:35:56 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Virt RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Beni Pelled 2020-10-27 14:18:27 UTC
Description of problem:

See: https://bugzilla.redhat.com/show_bug.cgi?id=1881325#c9

In an attempt to configure a wrong cluster cpu-type (secure -> non-secure) there is
a error message says [1] but the real issue is about setting a non-secure cpu-type,
(and the CPU is not really higher than what is set in the host - in my case I tryed
to set 'Intel Skylake Server Family' for a cluster with a CascadeLake host)

The error message should be updated.

[1] "Error while executing action: Cannot change Cluster CPU to higher CPU type when there are active Hosts with lower CPU type." 

Version-Release number of selected component (if applicable):
ovirt-engine-4.4.3.8-0.1.el8ev.noarch

Comment 2 Polina 2021-04-26 08:34:56 UTC
Verified on ovirt-engine-4.4.6.5-0.17.el8ev.noarch.

the new message - Error while executing action: Cannot change Cluster CPU type when there are active Hosts that do not support the selected CPU type.

Comment 3 Sandro Bonazzola 2021-05-05 05:35:56 UTC
This bugzilla is included in oVirt 4.4.6 release, published on May 4th 2021.

Since the problem described in this bug report should be resolved in oVirt 4.4.6 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.