Bug 189187 - Epson Stylus Photo R300 fails to eject last page
Epson Stylus Photo R300 fails to eject last page
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gimp-print (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: FC6Update
  Show dependency treegraph
 
Reported: 2006-04-17 22:15 EDT by Gerald Cox
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: F7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-18 10:40:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerald Cox 2006-04-17 22:15:30 EDT
Description of problem:
Upgraded to FC5 from FC4.  I have an Epson Photo R300 Printer.  I noticed that
when I print the CUPS test page, or print from an application such as GNUMERIC
or ABIWORD, the page doesn't eject from the printer when done.  The 
only way the page is ejected is I either turn the printer off then 
back on, or if I start another print job.  If I start another print 
job, the spacing for that next job is messed up.

I did notice in properties for the print queue there is a setting for 
"Send a FF" which wasn't checked.  I tried selecting that, but it 
doesn't make any difference.

If I print from within GIMP however, things appear to work normally.

Not sure if this is a gimp-print problem or related to CUPS or another 
print component.  The URL above is from another individual who is 
having the same problem.  The only difference is that he did a fresh install
rather than an upgrade.

This was also reported here:

https://sourceforge.net/tracker/index.php?func=detail&aid=1466678&group_id=1537&atid=101537

Version-Release number of selected component (if applicable):

gimp-print-4.2.7-16
cups-1.1.23-30.2

How reproducible:
Just print from any application.  Note, printing from within
gimp appears to work fine.

Steps to Reproduce:
1.  Print from ABIWORD, GNUMERIC or just test print from with the
system-config-print gui.
  
Actual results:
Last page does not eject from printer.  You have to power cycle the printer to
get the last page to clear.

Expected results:
At the end of the print job, the last page ejects from printer.

Additional info:
Comment 1 Anthony Messina 2006-04-18 22:08:22 EDT
I am having the same issue, and reported it originally at
https://sourceforge.net/tracker/index.php?func=detail&aid=1466678&group_id=1537&atid=101537

Note that the printer *does* eject the page when printing to it via samba/cups
with Windows driver from a Windows XP workstation.
Comment 2 Anthony Messina 2006-05-25 20:06:27 EDT
This bug has been marked as "fixed" from the gimp-print/gutenprint people.  see
the bug:
https://sourceforge.net/tracker/?func=detail&atid=101537&aid=1466678&group_id=1537
Comment 3 Gerald Cox 2006-05-29 21:42:38 EDT
I noticed this bug was put into the FC6 list.  Will this bug be fixed in FC5?
Comment 4 John Tapparo 2006-05-30 13:47:12 EDT
I am having the same problem, except that I have an Epson Stylus CX6600 (using
the CX6400 driver).  When printing with FC3, the printer worked fine.  I did a
new install of FC5 over the weekend (05/28/2006) and now the final page of a
print job does not eject (test page, print from Firefox are what I have tried. 
I have not tried any other applications yet).

I would like to see this fixed in FC5, am I dreaming?
Comment 5 Gerald Cox 2007-09-18 10:40:36 EDT
Fixed in F7.

Note You need to log in before you can comment on or make changes to this bug.