Bug 189198 - VLAN not working on initial startup
VLAN not working on initial startup
Status: CLOSED DUPLICATE of bug 188087
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
Depends On:
Blocks: 181409
  Show dependency treegraph
Reported: 2006-04-18 05:50 EDT by Michael Redinger
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-04-21 09:16:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michael Redinger 2006-04-18 05:50:03 EDT

When trying to use VLAN interfaces, the VLAN interface does not seem to be
brought up correctly:
No traffic is sent through that interface, even when explicitely sent there. The
VLAN interface statistic (in /proc) says that no packages where transmitted.
As soon as the network is restarted, things work fine. However, simply deleting
and adding the IP is not good enough.

- Software:
  Latest RHEL 4, all updates applied
- Hardware:
  2 onboard Broadcom Corporation NetXtreme BCM5721
  is is for the "normal" traffic, 1 for the VLANs


# this is the "default" interface
# does not seem to have anything to do with the problem, JIC


After configuring this and restarting the system, I try to ping my router:
$ ping -I eth1.261
PING ( from eth1.261: 56(84) bytes of data.
From icmp_seq=1 Destination Host Unreachable
From icmp_seq=2 Destination Host Unreachable

ifconfig and ip addr show output looks ok, eg.:
eth1.261  Link encap:Ethernet  HWaddr 00:16:35:9F:18:18
          inet addr:  Bcast:  Mask:
          RX packets:229 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:70640 (68.9 KiB)  TX bytes:0 (0.0 b)

However, /proc says that no packages where transmitted:
# cat /proc/net/vlan/eth1.261
eth1.261  VID: 261       REORDER_HDR: 1  dev->priv_flags: 1
         total frames received          578
          total bytes received        27766
      Broadcast/Multicast Rcvd            0

      total frames transmitted            0
       total bytes transmitted            0
            total headroom inc            0
           total encap on xmit            0
Device: eth1
INGRESS priority mappings: 0:0  1:0  2:0  3:0  4:0  5:0  6:0 7:0
EGRESSS priority Mappings:

When I run tcpdump on the VLAN interface, I can see (broadcast) packages - so
the /proc output seems ok.

arp for that interface does not seem to work either:
# arp -a
? ( at <incomplete> on eth1.261

When I now do a
/sbin/service network restart
Everything works fine:
- I can ping the gateway
- arp looks ok
- /proc/net/vlan/eth1.261 shows outgoing traffic
- my apps work fine on the interface

I tried to reproduce this a bit better:

- When I delete and add the IP address on the VLAN interface manually,
  the problem stays the same.
  (ip addr del ... ; ip addr add ...)
- When I delete the IP, take down the VLAN and re-add it, things work fine)
  (ip addr del ... ; vconfig rem ... ; vconfig add ... ; ip addr add ... )
- If I do not configure any VLAN interfaces at startup, but configure everything
  manually, the problem is stil the same.
  ( modprobe 8021q ; ifconfig eth1 up ; vconfig add ... ; ip addr add ... )
- Once this works for one VLAN interface, I can add other VLAN interfaces, and
  they work just fine.
- If I use eth1 as a "normal" interface, it works just fine.

Comment 1 Michael Redinger 2006-04-18 09:26:20 EDT
I just tried adding
/sbin/service network restart
to /etc/rc.d/rc.local.
However, even when I restart the system, the interface does not work properly.
If I login and run
everything works fine.
Comment 2 Jason Baron 2006-04-18 16:31:28 EDT
hmm...i think this is fixed in the latest beta kernel builds if you want to try
the kernel at: http://people.redhat.com/~jbaron/rhel4/
Comment 3 David Lawrence 2006-04-18 16:42:35 EDT
NEEDINFO_ENG has been deprecated in favor of ASSIGNED or NEEDINFO. Changing
status to ASSIGNED for ENG review.
Comment 4 Michael Redinger 2006-04-19 03:25:42 EDT
Yes, the test kernel works fine, thanks.
Comment 5 Jason Baron 2006-04-21 09:16:33 EDT

*** This bug has been marked as a duplicate of 188087 ***

Note You need to log in before you can comment on or make changes to this bug.